summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /dev-python/werkzeug
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest2
-rw-r--r--dev-python/werkzeug/werkzeug-3.0.3.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 76fded13869c..0e080b5b4b6d 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,4 +1,6 @@
AUX werkzeug-3.0.2-pytest-xprocess-1.patch 864 BLAKE2B ff18777cce9debbb39ae524a54912417a3d3bd46a54b4ba91322f9abe038b47e4091049f4e4ebb9bf5c0e661b0d88bea2d157b840d02d81442a323b222d840d2 SHA512 8208a0b6695d6079b0bf251bba8cf2c3c7fb89a37aadeb74c534e6c61a7455e71fb61ec6a44d2689a311e77d9d00302a7d2dafa449deb7d4e207038bd43ac372
DIST werkzeug-3.0.2.gh.tar.gz 817516 BLAKE2B 0c3324b6793f2fad77f62fbd0e3b847a73d6348d4a069dd83c852475d9cfa88feb3ab3ff1c4d547622b732de5fc3ba781d776d30f11ec1fae93cafdcfd9077eb SHA512 fdf44d2af517af69632909ae6fd5af327f34778c8f2dc7e606380123941102cc09d593a2036e843036e5abe998d2b2722f97b959eaeffc8de2b71a5b372a1e3e
+DIST werkzeug-3.0.3.tar.gz 803342 BLAKE2B 8c47d3131abeb8ce2d92291e08b603152210c44c40156b5399d24b167d0a02daf6adbeafec43e8b33dff940271feec95e9333e637e825f511cd5d03686c1e02e SHA512 fc771c161b37a376a86930c29c8b8052f81fb869cedea8c3c83af1e8b1aba271358c918e3067f3b0ac6d4a1689c8c355bff410d521c73a1909fd0ffc90fee6c6
EBUILD werkzeug-3.0.2-r1.ebuild 2022 BLAKE2B a20adda1e499c3643a959c7902726489c6743144bd25ce549ab0d829f5c0344defb4607f4ef2804aacf8f8f6561a7df0df6e27075cd669e0d865b0ee1a4e7842 SHA512 35ae3c60a3d6672c600b54faee710b8c9b9692693951c99c9978e3f455fcb628cc951442cf25764e205584402dea6c606aa4be2d662054662d6ff09dd00a5d49
+EBUILD werkzeug-3.0.3.ebuild 1984 BLAKE2B 236ac68369db3493771e122c93a652952835381908fa87d6c54bfd3e716200620a591d84a0e66a8e744cfbc26e9ccc747553c2f9c8da0cd5eb00df253b16be85 SHA512 a0203045681cee1bf24b124772efe792d7122325d93495285e3372276c195327fb0a1c7237231330876a2349776e4dccbe641b80fb74d89cfd76435053de3863
MISC metadata.xml 392 BLAKE2B 59644e2ff4cdd9ce2db59e36b9b3ec6ce7b7a87186c962bc6b1fa1ef490c30e542b62e8739b059a679f843af79ee7c8b13099bcbefa7ae3102aa3f5d1bf7055c SHA512 a79201b2e92c427248a4448a9734321f955e5431c46e0e58ead2e06c31945309c20f7de76f80e80d4c81ffb45deb4837e1a415a4d2596b7644b01735120899dd
diff --git a/dev-python/werkzeug/werkzeug-3.0.3.ebuild b/dev-python/werkzeug/werkzeug-3.0.3.ebuild
new file mode 100644
index 000000000000..3c1c6d1cf602
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-3.0.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xprocess-1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/pallets/werkzeug/issues/2875
+ "${FILESDIR}/${PN}-3.0.2-pytest-xprocess-1.patch"
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # RequestRedirect class started incidentally being tested
+ # with pytest-8, though the test isn't prepared for that
+ # https://github.com/pallets/werkzeug/issues/2845
+ 'tests/test_exceptions.py::test_response_body[RequestRedirect]'
+ )
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xprocess -p timeout tests
+}