summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 10:00:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 10:00:13 +0000
commit73ef00f9e2b100c7d0fedede11300940cc26670a (patch)
tree19d1f10cdd98aec4743c36942242eac9f318641d /dev-python/werkzeug
parent063e5b486db858a2b1ecec798af89f5484d475bd (diff)
gentoo auto-resync : 27:02:2023 - 10:00:13
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest2
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.2.ebuild64
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 58808dc7e1e0..017708423e34 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,5 +1,3 @@
-DIST werkzeug-2.2.2.gh.tar.gz 844463 BLAKE2B 84da3dd89375d6925e7e7018701339ddfd2b608acf6b3f126bd56c2020056511de6ab157de9024069d1342f9bce4b481ba91a06089fff1a3b31f4a851af7f935 SHA512 cded6c7e0b00871366b70a41de45e31323c0fc09300413d0efca98f5a2f8207026fd77c7e5670fde727da377fd02b9b636f390a2524d2b5778e9e3bdbdfe3e3a
DIST werkzeug-2.2.3.gh.tar.gz 847768 BLAKE2B 7d0b891a2b15e4fc469c3d331cfb2565f452ae77f772f7ab8e6254aedd172f9115cd3ebd9c82e951ea7505c0e58d6b6f07fb643a8e87af505e04686cccf56cd4 SHA512 3968e663f67e41da5148a4aa1d8e047ffd88416fa8df665e359bbe87992e4e723e1c915eed59ae86b53dd18817e41cdcef059483bce7aa8ed7b388dd4add1482
-EBUILD werkzeug-2.2.2.ebuild 1662 BLAKE2B 59159583aef75b5a349dfe04b8c688279109b672ec773f0507b065c8564e2e50ab04ef0b17c6597625fc8c23ae111cd0a93182b7249e75f36c8762d4a1e139fa SHA512 c6aa7b6b5c0c9eeb5fdab5917b7c30d969d4cbd5ffb47351687cb9df9110f269ca694e54d746d8eb2822dc3ec536b80d577f60ed8794036c8c00072216768555
EBUILD werkzeug-2.2.3.ebuild 1662 BLAKE2B 59159583aef75b5a349dfe04b8c688279109b672ec773f0507b065c8564e2e50ab04ef0b17c6597625fc8c23ae111cd0a93182b7249e75f36c8762d4a1e139fa SHA512 c6aa7b6b5c0c9eeb5fdab5917b7c30d969d4cbd5ffb47351687cb9df9110f269ca694e54d746d8eb2822dc3ec536b80d577f60ed8794036c8c00072216768555
MISC metadata.xml 368 BLAKE2B 81932229098620395623f9149ac974f19fae9b65ad09943ee5c5d8d03c1e37e76061291c959fe5f004f531a244b3bb335c2a43dd66949c0be43493e45674d0e3 SHA512 67e5b5fea8052c0723820125271ea031ad984e0fe2af21d2423fc559bdc51dfe1d40f2fa5fe11e6d2b8b32216e716900080b859aad146c079ad2b390dd9844cf
diff --git a/dev-python/werkzeug/werkzeug-2.2.2.ebuild b/dev-python/werkzeug/werkzeug-2.2.2.ebuild
deleted file mode 100644
index 7e2db22b86dc..000000000000
--- a/dev-python/werkzeug/werkzeug-2.2.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="
- https://palletsprojects.com/p/werkzeug/
- https://pypi.org/project/Werkzeug/
- https://github.com/pallets/werkzeug/
-"
-SRC_URI="
- https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test-rust"
-
-RDEPEND="
- >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
-"
-# NOTE: remove the loong mask after greenlet gains support for loong
-# see https://github.com/python-greenlet/greenlet/pull/257
-BDEPEND="
- test? (
- dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- test-rust? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- )
- !hppa? ( !ia64? ( !loong? (
- $(python_gen_cond_dep '
- dev-python/greenlet[${PYTHON_USEDEP}]
- ' python3_{8..10})
- ) ) )
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- "tests/test_serving.py::test_server[https]"
- tests/test_serving.py::test_ssl_dev_cert
- tests/test_serving.py::test_ssl_object
- )
- fi
-
- # the default portage tempdir is too long for AF_UNIX sockets
- local -x TMPDIR=/tmp
- epytest -p no:django -p no:httpbin tests
-}