summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug/werkzeug-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/werkzeug/werkzeug-0.16.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/werkzeug/werkzeug-0.16.0.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-0.16.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/werkzeug/werkzeug-0.16.0.ebuild b/dev-python/werkzeug/werkzeug-0.16.0.ebuild
new file mode 100644
index 000000000000..2543d391d0d9
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.16.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
+#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="https://github.com/pallets/werkzeug/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # dev_server seems to be broken with PyPy
+ # https://github.com/pallets/werkzeug/issues/1668
+ # TODO: exclude only failing tests
+ [[ ${EPYTHON} == pypy ]] && continue
+
+ pytest -vv -p no:httpbin || die "Tests fail with ${EPYTHON}"
+}