summaryrefslogtreecommitdiff
path: root/dev-python/webtest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/webtest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/Manifest5
-rw-r--r--dev-python/webtest/metadata.xml11
-rw-r--r--dev-python/webtest/webtest-2.0.21.ebuild67
-rw-r--r--dev-python/webtest/webtest-2.0.29.ebuild66
4 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
new file mode 100644
index 000000000000..da70da55908b
--- /dev/null
+++ b/dev-python/webtest/Manifest
@@ -0,0 +1,5 @@
+DIST WebTest-2.0.21.tar.gz 66866 BLAKE2B d2830fcce7fb4b91029838806952e3e9c6916c3b292c7142138f30486d936b4a1f0c2d28a5973b0c351c64e499f343f3711296c6e37c38548e3a81b108163a17 SHA512 21f58ee9192fd0eb0eb2d88179ffc015aa5cf04c8004db251bd65d13d54c34b9e6b5fc9fdd8e9fcbbc18fcfb2be714c0691b2ef034318861262f8705b4a44610
+DIST WebTest-2.0.29.tar.gz 74620 BLAKE2B 7fc68f1178b1abb0a0f126112b846853762ad78cb060718bc340f5ba17517180b7283f384503ff77a2c7396645ebe2d5528dbc0f027c5d44beb002c4204bf894 SHA512 319700d1444f6a681f8ed8a4ee8661ba0462b3f4bfeb7510232f58be92e017066da3bac494ebe1a3c5b9f2d06c025e08e6193277e13c6113e9485108d4ccd2d2
+EBUILD webtest-2.0.21.ebuild 1806 BLAKE2B c368d64119cfb3289d1957482f18e1d9d601e3a7da4c50ca8b3873366d30cbf95fcf33d00ebdd28c3df55c0b3b28b9b1bb09b34f26960ea36f4af407d5ed18aa SHA512 ae3c51bf50c24db69981ac662c96a9090247d996074334a2b3ac97e546c9472abff270798ca4b637dd320af6c7437b07ebf5f7a8bc96019aeb734ad8a17d442f
+EBUILD webtest-2.0.29.ebuild 1771 BLAKE2B 6ea67d3b4fa5ef0c10a631613814b6cfc11f20d5017394bb5b1b1fae522c4c3d05d96efb751a1f83fb6d06afc8c564ce7fcf73e671b9c962fe76e614984a1cbf SHA512 20b48baa23f700b43a07ed966010b951f438f90687f2613ce1b2494fda5f6d77d223a38322c61f48e55391f515116d4863a13149843c2bcae1e17c16b3365650
+MISC metadata.xml 310 BLAKE2B 34f814fb04671947a228986ee91f8eaafec5a2931cdb87c63b8e135130dc60eff1a2fc2d15f0aba767fac07d853ffcdc339dfdd02495ccc40830b5452b6173d1 SHA512 0fb6e471cf00fcbea309bdb63d23c5917250f2de2e3e245a91d6ccf1258123ee6f0a8c3f311c526b7f9062c6ed93df1c89f44abf16879440dd1dc81c7fba2743
diff --git a/dev-python/webtest/metadata.xml b/dev-python/webtest/metadata.xml
new file mode 100644
index 000000000000..0990b16f82a6
--- /dev/null
+++ b/dev-python/webtest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">WebTest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/webtest/webtest-2.0.21.ebuild b/dev-python/webtest/webtest-2.0.21.ebuild
new file mode 100644
index 000000000000..9f5bd8741ddc
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.21.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="https://pypi.org/project/WebTest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc64 ~s390 ~sh sparc x86"
+IUSE="doc test"
+
+# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Makes testing easier; otherwise we get errors from pkg_resources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ # Tests raise ImportErrors with our default PYTHONPATH.
+ local -x PYTHONPATH=
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/webtest/webtest-2.0.29.ebuild b/dev-python/webtest/webtest-2.0.29.ebuild
new file mode 100644
index 000000000000..f7981a6395b9
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.29.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="https://pypi.org/project/WebTest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc64 ~s390 ~sh sparc x86"
+IUSE="doc test"
+
+# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Makes testing easier; otherwise we get errors from pkg_resources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ # Tests raise ImportErrors with our default PYTHONPATH.
+ local -x PYTHONPATH=
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}