summaryrefslogtreecommitdiff
path: root/dev-python/websockify/websockify-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/websockify/websockify-0.9.0-r1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/websockify/websockify-0.9.0-r1.ebuild')
-rw-r--r--dev-python/websockify/websockify-0.9.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/websockify/websockify-0.9.0-r1.ebuild b/dev-python/websockify/websockify-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..3e94e67a53ce
--- /dev/null
+++ b/dev-python/websockify/websockify-0.9.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+# entry_points is used
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/kanaka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="https://github.com/kanaka/websockify"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/jwcrypto[${PYTHON_USEDEP}] )"
+
+# Backport a patch removing the need for mox3
+PATCHES=( "${FILESDIR}/${P}-mock-tests.patch" )
+
+distutils_enable_tests nose
+
+python_install_all() {
+ doman docs/${PN}.1
+ distutils-r1_python_install_all
+}