summaryrefslogtreecommitdiff
path: root/dev-python/websockify/websockify-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/websockify/websockify-0.8.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/websockify/websockify-0.8.0.ebuild')
-rw-r--r--dev-python/websockify/websockify-0.8.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/websockify/websockify-0.8.0.ebuild b/dev-python/websockify/websockify-0.8.0.ebuild
new file mode 100644
index 000000000000..4cff30d2c15b
--- /dev/null
+++ b/dev-python/websockify/websockify-0.8.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/kanaka/${PN}/archive/v${PV}.zip -> ${P}.zip"
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="https://github.com/kanaka/websockify"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"