summaryrefslogtreecommitdiff
path: root/dev-python/websockify/websockify-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/websockify/websockify-0.10.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/websockify/websockify-0.10.0.ebuild')
-rw-r--r--dev-python/websockify/websockify-0.10.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/websockify/websockify-0.10.0.ebuild b/dev-python/websockify/websockify-0.10.0.ebuild
deleted file mode 100644
index 2998d8ecf9be..000000000000
--- a/dev-python/websockify/websockify-0.10.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="WebSockets support for any application/server"
-HOMEPAGE="https://github.com/novnc/websockify"
-SRC_URI="
- https://github.com/novnc/websockify/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/jwcrypto[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO: incompatible with current jwcrypto? (not a regression)
- tests/test_token_plugins.py::JWSTokenTestCase::test_asymmetric_jwe_token_plugin
- )
- epytest ${deselect[@]/#/--deselect }
-}
-
-python_install_all() {
- doman docs/${PN}.1
- distutils-r1_python_install_all
-}