summaryrefslogtreecommitdiff
path: root/dev-python/websockets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
commitaef01e7679692cb2cf9eca0c03865cfd0a4e33c9 (patch)
tree4a000095846b696df937b27f28c2483b902028c7 /dev-python/websockets
parentfbf0c3d1b463bf45fb0e9f119bec3424d6a44a4f (diff)
gentoo auto-resync : 01:09:2023 - 16:14:02
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/websockets-11.0.3-r2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index a49f36011118..eab7b8c5fe1b 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -3,5 +3,6 @@ DIST websockets-11.0.3-python3.12.patch.xz 4328 BLAKE2B 6ef94255ef5d95de8015eca1
DIST websockets-11.0.3.gh.tar.gz 347652 BLAKE2B b7d796744cb4c7b944e98644dfb9c0e44ba465a6dba71b9e891604f3012b025557dbcd5b7eeae02e71c84350e05b334f99404ddfda814a8984b7a893d3f092f7 SHA512 37a84d7c57da7a3e48870abf992ba96ee454b342610d51c06f7dfc7ee082b7fb51304518c208379c3dbd039eafb1a85444c257fed20b4605a52dc8fc938a4cca
EBUILD websockets-11.0.2.ebuild 1005 BLAKE2B c2229a9c6c0ff0d0d6c9a28d360d88c6ea3405b090faf44cd513b00cf52d78946efd068e033d71b6ba5c1ff96b791c3d6d157d22888b8724c898093fcdd594c7 SHA512 2764a495ba3d6b14f27f5d845d18454a85b8f0628f7b925a4a1d0c3fcdb965b39e22346363ea5ff33403c92c1d5b3eab43d6a7c1ec9080420ecfee57f8f35cc3
EBUILD websockets-11.0.3-r1.ebuild 1375 BLAKE2B c54ddd8a15c7e43f4dc069cb5fd1b2056ae102f638519d77bd91755ec056689d419c1b1d637ed3175ab33a9fce5d0edfa1f7abf6a09e147578edf51365e55c75 SHA512 af4b4944771f31d08cdabbf353f01c07394f8ccaaf89e1674928cd2f8e9b6e48f8659a6d175b0386c784e8580746fa1f472c3a7d671fcfc7ad8aa2dd31231523
+EBUILD websockets-11.0.3-r2.ebuild 1494 BLAKE2B 6a02fbb8c133c5c2f7eb1c88b114f5d00c0d5ba2a2bf817099f542cc948c2cc2f7bba842e30b1066b125b36675d980d0198599fff24f990050168f730195b664 SHA512 b7a6fd82fcbc322c8c227984dcc6da880ba278b008a4f56af1e9d87167f49475ed572da85a43f6e3809baf8aaeec74c6e06a78bccbef34cc883f6330321af4d7
EBUILD websockets-11.0.3.ebuild 1013 BLAKE2B f8b2d509b466a75cd17c15201088f4e1fbad9e8ddc8ea7f42462de22d605fd6cd45166124ed304c0f0c4223ff0cd04824292f68e6ff8f0b7907f30ae1dea3ca0 SHA512 a3332e0789f5dd0db76b4bee90af78920c2a78c60c242314cbecba2a6ec032ebef0ad96cf685daa4bd6aa5260a16ed9fc2c6e0affda14a98cd537bb2a8e91053
MISC metadata.xml 580 BLAKE2B 66a318a73b2a9e37f44a28dfc9ed5f1aa7193edb05fa295bde27fd7a1c429cae1d875289ac5bd8ff7b579be2cfc5671d27dfb46ba959c47b2c1074e8e549e9c3 SHA512 c4ba79e5ec539ffb6f0338e6e161132dc8dd0e6c7e7533df1c32731810126b728076703a542bb28abc159842ad71bd42e69e36f4fe17dc3377d054d21ec53dbf
diff --git a/dev-python/websockets/websockets-11.0.3-r2.ebuild b/dev-python/websockets/websockets-11.0.3-r2.ebuild
new file mode 100644
index 000000000000..cfbf2d5a02db
--- /dev/null
+++ b/dev-python/websockets/websockets-11.0.3-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/python-websockets/websockets/
+ https://pypi.org/project/websockets/
+"
+# tests are missing pypi sdist, as of 11.0
+SRC_URI="
+ https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-11.0.3-python3.12.patch.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${WORKDIR}"/${P}-python3.12.patch
+)
+
+python_compile() {
+ if use native-extensions && [[ ${EPYTHON} != pypy3 ]] ; then
+ local -x BUILD_EXTENSION=yes
+ else
+ local -x BUILD_EXTENSION=no
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ # requires DNS access
+ # https://bugs.gentoo.org/909567
+ tests/legacy/test_client_server.py::ClientServerTests::test_explicit_host_port
+ tests/legacy/test_client_server.py::SecureClientServerTests::test_explicit_host_port
+ )
+
+ epytest tests
+}