summaryrefslogtreecommitdiff
path: root/dev-python/websockets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-python/websockets
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest2
-rw-r--r--dev-python/websockets/websockets-10.4.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 00868d572959..45f1372bc8e9 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,4 +1,6 @@
AUX websockets-10.3-py311.patch 1065 BLAKE2B 16e66f28b0b1bd68b28bafd91ff83fd72d295ff52fa53420ec4a9be31ae66c4b0f4e515b8c62feba616cd6d3650af30566c97f157dec469f2f3de5e584eb0b7f SHA512 94c34e96b9d6ee75599be33bb246ac21a41763f51dc59255632273f8d46d0553f275c9e888615adda93047ab65eeb577dab64a5153c1cb3155c27f9618c0c961
DIST websockets-10.3.gh.tar.gz 304375 BLAKE2B db6075304613ff74ad5928a0c57e90a7d418ac0b9532adba4c6a17b3c3f1982cc94db8ac4c0da5f65343a915f3b2e7ccedce4e6d5d4960cb72fc93c3db6e041c SHA512 75a11dd7605808954c5f59decda5b115db73de96ed4023d8d7ee3c9966551a9ded2d771f76b086c76f49b0787f19349dadcd9010eb5fea8eeddf3d9bba1c6cbb
+DIST websockets-10.4.gh.tar.gz 309611 BLAKE2B f3a739368ff9d78fef79324af59d1e77b3fb654b8b1a847373a29f19b11ae9266b9a938d235ee27d12b59d9b4cf29825fc7298ff2f35e5b260df2c7a41a1bd78 SHA512 087b1920ff26e21b8d3b80b53249d44b841fc45a4992df1ad725112404f724a41aaa2d759a2bd521dfe337459f8bf0d2ae048c423489f527c68f6825f928b582
EBUILD websockets-10.3.ebuild 871 BLAKE2B b97e0aee91257ce1bb254f0e81017bc49d488d332d6206ad3dd9a429218f6d7f9ba0d185b6bc59160f638a4e0d1b81caa046e70afa9829bd3f615a1006f420c6 SHA512 d25050228fe2fcffad26943fa4b54e4cefedb73e4894cdab4e301e5f5d942e53edb769daa7cea808e09c29c85f0da202f52fa209339dd6ada1e87e56a2682154
+EBUILD websockets-10.4.ebuild 834 BLAKE2B d4e9f008874c530ac2bec8b35045011a4e70a28cfea69521aa4a5d53da0131366d194edc94140fb4e18ab21050d6ebc30601283318e558b74c1bf68885fbdcd6 SHA512 31377f86cd37787f32a8e049afd59e28510a2f23746927d2530374bf5a9267721b36958d162896827975904411a847ae7ca195b3383b9c6b911c7aa2011c7312
MISC metadata.xml 488 BLAKE2B 06ed81aa4ffa49d1951a8ef639752bc701d798fa531737d4cb367ca198e65178f430d6b1e7f3b24ffcc332343dd58a0cc8ff5f2632a225e6c0f36ee50148aebd SHA512 8335bde47d396c018b32db406e18636edd7f3fe5704c901888d56690ec726aeb7d6f9e42fb7dbb1869c78b494c9cbc17ded3ca78b7576d6fdc0a8097bf996f60
diff --git a/dev-python/websockets/websockets-10.4.ebuild b/dev-python/websockets/websockets-10.4.ebuild
new file mode 100644
index 000000000000..12d175fce31a
--- /dev/null
+++ b/dev-python/websockets/websockets-10.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/aaugustin/websockets/
+ https://pypi.org/project/websockets/
+"
+SRC_URI="
+ https://github.com/aaugustin/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ )
+
+ epytest tests
+}