summaryrefslogtreecommitdiff
path: root/dev-python/websockets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-22 08:45:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-22 08:45:32 +0100
commit940cec7afea0fff03b206c62a512335e6f9d2d00 (patch)
tree719c138f497dce562bd86f32bec882f5a4220459 /dev-python/websockets
parent752353adf60f88b9de2c3c752a871b9f907e2acb (diff)
gentoo auto-resync : 22:10:2023 - 08:45:32
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest2
-rw-r--r--dev-python/websockets/websockets-12.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 0d22bb7cd1c1..c567393d6093 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,4 +1,6 @@
DIST websockets-11.0.3-python3.12.patch.xz 4328 BLAKE2B 6ef94255ef5d95de8015eca14a5110373ab9ffadf4d1c86a892da1aac46caa2755cafeb643a222000a03262c1b1b1aea58132daff36981c00dbb68ce05484058 SHA512 421a6fb5a2a801850ea1fbaf890c11eac0f55ad288185f16f4244f316132591bc5a814636141ba3ada67aeff340f41de61d06c8db87010c858c1b0b02fd9b5ab
DIST websockets-11.0.3.gh.tar.gz 347652 BLAKE2B b7d796744cb4c7b944e98644dfb9c0e44ba465a6dba71b9e891604f3012b025557dbcd5b7eeae02e71c84350e05b334f99404ddfda814a8984b7a893d3f092f7 SHA512 37a84d7c57da7a3e48870abf992ba96ee454b342610d51c06f7dfc7ee082b7fb51304518c208379c3dbd039eafb1a85444c257fed20b4605a52dc8fc938a4cca
+DIST websockets-12.0.gh.tar.gz 352120 BLAKE2B cab704e0ee44a7012ee58d515a5ea7380a97a3cbb8f55d105c00c8c2b9ed992b4c87435875474de32e5969fd92256bdec830db0571399a1d2e5fb719b23c2d83 SHA512 f17943d444ce275b709cf89453b2d2cce09f5af26f0460e226c2e24cfbb425c825963352e130dcd4201587606355375b525d8e5a02eccbffbb3985a108a3ed5e
EBUILD websockets-11.0.3-r2.ebuild 1486 BLAKE2B ea9991ebd3c46ee6d057a44d8596c75a74879ce1f661cf9ce1d05e975be2ec451cd897d31da5266a518b9cf333013c3f61d2e23a20341812a4c1959217e9ccc3 SHA512 ae6aca3c8a3b1ca538250ea1257c7723eb9650bbf81de0cb9cbdcf3727fe9086130ea0c598d1826eb478d9c6dbf8c41d94069a3162e4a886477f9ce064d1fb0e
+EBUILD websockets-12.0.ebuild 1434 BLAKE2B 5c6cb842e6b333f31b4c65d661a38b69e08146cd843f51343ca4e590a487d962d577c8c2c50ce4cbd6dd99d9cbbdc759e29b3c0aa1a0a55b1c753287f1f71e13 SHA512 b8a6104ece0a37e865cdb6453c10421d3d5dc1dacb07bae1f11744e7766c395efb8c1ece330b734e6024a69d4e24dc500bf332316c3c3079dae7bc991d3260a1
MISC metadata.xml 580 BLAKE2B 66a318a73b2a9e37f44a28dfc9ed5f1aa7193edb05fa295bde27fd7a1c429cae1d875289ac5bd8ff7b579be2cfc5671d27dfb46ba959c47b2c1074e8e549e9c3 SHA512 c4ba79e5ec539ffb6f0338e6e161132dc8dd0e6c7e7533df1c32731810126b728076703a542bb28abc159842ad71bd42e69e36f4fe17dc3377d054d21ec53dbf
diff --git a/dev-python/websockets/websockets-12.0.ebuild b/dev-python/websockets/websockets-12.0.ebuild
new file mode 100644
index 000000000000..d6c08f6e7319
--- /dev/null
+++ b/dev-python/websockets/websockets-12.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/python-websockets/websockets/
+ https://pypi.org/project/websockets/
+"
+# tests are missing pypi sdist, as of 11.0
+SRC_URI="
+ https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-11.0.3-python3.12.patch.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ if use native-extensions && [[ ${EPYTHON} != pypy3 ]] ; then
+ local -x BUILD_EXTENSION=yes
+ else
+ local -x BUILD_EXTENSION=no
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires DNS access
+ # https://bugs.gentoo.org/909567
+ tests/legacy/test_client_server.py::ClientServerTests::test_explicit_host_port
+ tests/legacy/test_client_server.py::SecureClientServerTests::test_explicit_host_port
+ )
+
+ epytest tests --reruns=10 --reruns-delay=2
+}