summaryrefslogtreecommitdiff
path: root/dev-python/websockets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
commit2f210c93c08515a806199783aabe37d12a0197cb (patch)
tree8b846898d136de0503e4ec3c2cf1f90660ee3336 /dev-python/websockets
parent1c19f0d8d940b35f723e28d8a6ebe388cfacd1d8 (diff)
gentoo auto-resync : 30:05:2023 - 21:21:38
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest2
-rw-r--r--dev-python/websockets/websockets-11.0.3-r1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 95b6e86ff8bc..844f0a3132be 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,5 +1,7 @@
DIST websockets-11.0.2.gh.tar.gz 347575 BLAKE2B 1d609298d072dbd986fa2adcac1c8f80720622fdcd44cb8ab079ba812fa7a750cdd4a5b432a74d422ca3ac8e7baef8e38e227569b8681e033f599fa29b19383c SHA512 e397d7b51c3edcc68fd32dbf8fcd46f5c9230c270be46c45a503108690d5513e2626fc4f4f5d271c831570abeeff51bf27c09ea69459b970a41fb64eb84fc87e
+DIST websockets-11.0.3-python3.12.patch.xz 4328 BLAKE2B 6ef94255ef5d95de8015eca14a5110373ab9ffadf4d1c86a892da1aac46caa2755cafeb643a222000a03262c1b1b1aea58132daff36981c00dbb68ce05484058 SHA512 421a6fb5a2a801850ea1fbaf890c11eac0f55ad288185f16f4244f316132591bc5a814636141ba3ada67aeff340f41de61d06c8db87010c858c1b0b02fd9b5ab
DIST websockets-11.0.3.gh.tar.gz 347652 BLAKE2B b7d796744cb4c7b944e98644dfb9c0e44ba465a6dba71b9e891604f3012b025557dbcd5b7eeae02e71c84350e05b334f99404ddfda814a8984b7a893d3f092f7 SHA512 37a84d7c57da7a3e48870abf992ba96ee454b342610d51c06f7dfc7ee082b7fb51304518c208379c3dbd039eafb1a85444c257fed20b4605a52dc8fc938a4cca
EBUILD websockets-11.0.2.ebuild 1005 BLAKE2B c2229a9c6c0ff0d0d6c9a28d360d88c6ea3405b090faf44cd513b00cf52d78946efd068e033d71b6ba5c1ff96b791c3d6d157d22888b8724c898093fcdd594c7 SHA512 2764a495ba3d6b14f27f5d845d18454a85b8f0628f7b925a4a1d0c3fcdb965b39e22346363ea5ff33403c92c1d5b3eab43d6a7c1ec9080420ecfee57f8f35cc3
+EBUILD websockets-11.0.3-r1.ebuild 1153 BLAKE2B cd37c008d3812585493428ce9c846286c9663fbc721210345677b5458ec659beb821a406d19a2829b87795b1a2e3fc80ebac6366c9962a49b70e82cac68a302f SHA512 10491c4a257db96e981dfc39c4997c7fcc9237419fe5b8d74939587c3425268cd548b07df08c055d23e0511c2f029a8957b953d6317b26ec7e039abfcf1b5d6e
EBUILD websockets-11.0.3.ebuild 1013 BLAKE2B f8b2d509b466a75cd17c15201088f4e1fbad9e8ddc8ea7f42462de22d605fd6cd45166124ed304c0f0c4223ff0cd04824292f68e6ff8f0b7907f30ae1dea3ca0 SHA512 a3332e0789f5dd0db76b4bee90af78920c2a78c60c242314cbecba2a6ec032ebef0ad96cf685daa4bd6aa5260a16ed9fc2c6e0affda14a98cd537bb2a8e91053
MISC metadata.xml 580 BLAKE2B 66a318a73b2a9e37f44a28dfc9ed5f1aa7193edb05fa295bde27fd7a1c429cae1d875289ac5bd8ff7b579be2cfc5671d27dfb46ba959c47b2c1074e8e549e9c3 SHA512 c4ba79e5ec539ffb6f0338e6e161132dc8dd0e6c7e7533df1c32731810126b728076703a542bb28abc159842ad71bd42e69e36f4fe17dc3377d054d21ec53dbf
diff --git a/dev-python/websockets/websockets-11.0.3-r1.ebuild b/dev-python/websockets/websockets-11.0.3-r1.ebuild
new file mode 100644
index 000000000000..a6f179e672f2
--- /dev/null
+++ b/dev-python/websockets/websockets-11.0.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/python-websockets/websockets/
+ https://pypi.org/project/websockets/
+"
+# tests are missing pypi sdist, as of 11.0
+SRC_URI="
+ https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-11.0.3-python3.12.patch.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${WORKDIR}"/${P}-python3.12.patch
+)
+
+src_configure() {
+ export BUILD_EXTENSION=$(usex native-extensions)
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ )
+
+ epytest tests
+}