summaryrefslogtreecommitdiff
path: root/dev-python/webencodings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /dev-python/webencodings
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'dev-python/webencodings')
-rw-r--r--dev-python/webencodings/Manifest2
-rw-r--r--dev-python/webencodings/webencodings-0.5.1-r2.ebuild13
2 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/webencodings/Manifest b/dev-python/webencodings/Manifest
index 41794638bc99..e951fd2e8e23 100644
--- a/dev-python/webencodings/Manifest
+++ b/dev-python/webencodings/Manifest
@@ -1,3 +1,3 @@
DIST webencodings-0.5.1.tar.gz 9721 BLAKE2B f62ee91cf0230f55bfbe9973a621bbaf3aa250f511b2e1e2c0c6db00bf52760bb058957040600cb33d6f9208987302a70783b04325be4ff344c428a43664290a SHA512 b727b01bac6ec79bca517960d27b4c0668b295f25559471b9641c2c33dab55db6dac9c990952177964c6418382c22831b14d57df5e632d51d7abf97b61f24326
-EBUILD webencodings-0.5.1-r2.ebuild 706 BLAKE2B c05432ce937ddf9d43bac3f3a3344750a0c5db92fba233b21c82d57b8759f040478f55122b3b1d11e5b338de4430205c1c36114f20700258537dbaee505ba215 SHA512 a7a3cf1c7924f211a284c706d85fe0c05fa9b7cd1f6ff79e6543e213d309bad285c3110f8a02ff65237b3b7a630fcc0aca8f4f3a5e6b0fda1de4e3bf353a8fec
+EBUILD webencodings-0.5.1-r2.ebuild 667 BLAKE2B cb8f7b496b360e55e1650d7b94d3d07bf2c95a828e8ce9373556de96598bfcf716cf9d318050aa672bfabdfeba3d96b53fbe54d21ef05b13027abd2be9c9cd0c SHA512 402fb153173352b86341901765f7cfebf83e5c54afa2c832c114d76e8b4f2859ccc21d219f0cbf0bc2d4a15ad59b6074c5efb2dca22e151319f7805082c32c7c
MISC metadata.xml 476 BLAKE2B dc58a60145a5cdbc0c901f4fcfcbce6ceb56c59cea3b5fa25938715582e93ece0736fc18b22fe7b8d5011e8959e6ea835fc872dcc9c5b694ab08e28e4ad4793a SHA512 3145cc3f9b865825c08dc7fbb80ca45308b2b001495143939e3fe07af382050f3e1b026d81daea6706f85de59311d139090d16c082e3ad637394a4801dfba8da
diff --git a/dev-python/webencodings/webencodings-0.5.1-r2.ebuild b/dev-python/webencodings/webencodings-0.5.1-r2.ebuild
index 4f1fd148ae77..9e8153aaa871 100644
--- a/dev-python/webencodings/webencodings-0.5.1-r2.ebuild
+++ b/dev-python/webencodings/webencodings-0.5.1-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -20,10 +20,7 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
distutils_enable_tests pytest
-python_prepare_all() {
- cat >> setup.cfg <<- EOF || die
- [tool:pytest]
- python_files=test*.py
- EOF
- distutils-r1_python_prepare_all
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o 'python_files=test*.py'
}