summaryrefslogtreecommitdiff
path: root/dev-python/webcolors/webcolors-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/webcolors/webcolors-1.8.1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/webcolors/webcolors-1.8.1.ebuild')
-rw-r--r--dev-python/webcolors/webcolors-1.8.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/webcolors/webcolors-1.8.1.ebuild b/dev-python/webcolors/webcolors-1.8.1.ebuild
new file mode 100644
index 000000000000..d3a857f49790
--- /dev/null
+++ b/dev-python/webcolors/webcolors-1.8.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Color names and value formats defined by the HTML and CSS specifications"
+HOMEPAGE="https://pypi.org/project/webcolors/ https://github.com/ubernostrum/webcolors"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --verbose || die
+}