summaryrefslogtreecommitdiff
path: root/dev-python/webassets/webassets-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/webassets/webassets-2.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/webassets/webassets-2.0.ebuild')
-rw-r--r--dev-python/webassets/webassets-2.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/webassets/webassets-2.0.ebuild b/dev-python/webassets/webassets-2.0.ebuild
index 15cc85186663..c5a300af7a64 100644
--- a/dev-python/webassets/webassets-2.0.ebuild
+++ b/dev-python/webassets/webassets-2.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -24,7 +24,12 @@ BDEPEND="
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
!!dev-ruby/sass
- )"
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0-python39.patch"
+)
distutils_enable_tests pytest