summaryrefslogtreecommitdiff
path: root/dev-python/webassets/webassets-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/webassets/webassets-0.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/webassets/webassets-0.12.ebuild')
-rw-r--r--dev-python/webassets/webassets-0.12.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/webassets/webassets-0.12.ebuild b/dev-python/webassets/webassets-0.12.ebuild
new file mode 100644
index 000000000000..8dc45cda391c
--- /dev/null
+++ b/dev-python/webassets/webassets-0.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asset management for Python web development"
+HOMEPAGE="https://github.com/miracle2k/webassets"
+SRC_URI="https://github.com/miracle2k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# ^^ pypi tarball is missing tests
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # webassets wants /usr/bin/babel from babeljs,
+ # but we have only one from openbabel
+ # ... and we don't have postcss
+ sed -i \
+ -e 's|\(TestBabel\)|No\1|' \
+ -e 's|\(TestAutoprefixer6Filter\)|No\1|' \
+ tests/test_filters.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die
+}