summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 20:08:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 20:08:44 +0000
commit6554f04b9a44e1ffe5d2f614201c11deed2703bd (patch)
tree4a6f98988d23282385c916fa1c677b094d10461a /dev-python/weasyprint
parent7c9730bcb62df7cbf8248c5db9a478aac52c60ea (diff)
gentoo auto-resync : 17:02:2023 - 20:08:44
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest2
-rw-r--r--dev-python/weasyprint/weasyprint-58.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index b1482f98d7d7..ffddb1a16c04 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,5 +1,7 @@
DIST weasyprint-57.1.tar.gz 429652 BLAKE2B c94cc05f6c3b831d3214d7476e3fa799ff62d8fb575044a6f11172e650a87b1277e21fef40577bb01a1a778982a98e1a57801de708b3a3a26520b50aae8b43ac SHA512 0a130fba07d1d73eb4e9dcda27ab51ede45c440717f6fedb8d6aac09283244c366d36d85c2dac85995fbaebac21cf880a0cb684baaff3788af3eb6b4931c014b
DIST weasyprint-57.2.tar.gz 429120 BLAKE2B c97ba3fb3eec431a7de9a1a8a440290005de11b11d4abac4dd993a7d2fc4c14e64bdf13b8f8c12d4ba4f94b2049e0b05c3fb950c8b204f446323038c9c471451 SHA512 11b9469d37820439b1d0dad0117dd1c9649011c71aabb0e27008b303e5c851215ce9f0b271da9a74d614e54cb23f9c6036b6e094016b5688f6b700fb7444338f
+DIST weasyprint-58.0.tar.gz 433708 BLAKE2B 3ebb87eeeefad8d8a1a6a5d1ec54bef5cd153e8f837d19f87ce6ee891d4a20d41b38532972e9942e4d2123107491db42e0d690a95b8330510010ec2267c2948b SHA512 6c8258b1539ba7c6c692d0a54d0adb36a252d9f1a407df7934cf37202813e08e16e97d2f70a322a2787e2ab64545f4a4fd745fe4771b9383f520b9fc8d51db28
EBUILD weasyprint-57.1-r1.ebuild 1072 BLAKE2B ec59498015c698c0e6dd02a33c07691261c88c20f5efcece07cf754689c7d3085899b954288c4017b2ab5e136dd334b2d5b6675b6760888350d631aae39c0e79 SHA512 b74bb9363e33a0b7a9886eb8332bd288c88ba058e246901fb9a441254ac5807523b402a9e0e0c121c657194b92690d825566a21f10f4c24046a659f308deb838
EBUILD weasyprint-57.2-r1.ebuild 1073 BLAKE2B 282e3875289d148247ea68fca2f80defd15d16975855338417435027ba00500af448d76bf6c906a3106ab820f3b6d96eb91da02be4c9a269dd1684ce7055f544 SHA512 b051452c64790d5cc7d3e4a644e7fc87c70f02564c2ac06ad23f2d9f81a34ca4e211b9441d8b006b49164b9b49516593b1e278a15fa3b32bc466484c64aa1f07
+EBUILD weasyprint-58.0.ebuild 1073 BLAKE2B 282e3875289d148247ea68fca2f80defd15d16975855338417435027ba00500af448d76bf6c906a3106ab820f3b6d96eb91da02be4c9a269dd1684ce7055f544 SHA512 b051452c64790d5cc7d3e4a644e7fc87c70f02564c2ac06ad23f2d9f81a34ca4e211b9441d8b006b49164b9b49516593b1e278a15fa3b32bc466484c64aa1f07
MISC metadata.xml 382 BLAKE2B 3e5d142b055354e1ea440d9efd4bf92458b1da3f777dd90929ce2041ca6e0969fa6e58aacfb4a5a93ff90805e0d8ec4c9c6253559ca54698f5029639ce35ac8a SHA512 43415064a6f56eaca974031e51d63118d1c65b33e4399302fc72cc2cd6f15e0a47cf411b18d3c5136e866115855deb19b6a9e058a18049151959ce5ee29ececf
diff --git a/dev-python/weasyprint/weasyprint-58.0.ebuild b/dev-python/weasyprint/weasyprint-58.0.ebuild
new file mode 100644
index 000000000000..c9362f1c7799
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-58.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ || (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ <app-text/ghostscript-gpl-9.56.0
+ )
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest