summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
commit4c5bd80830992553e02f099442277e10ee97372d (patch)
treebeeb8ff1f9d6f5b48418cc2134cec247aaade4e4 /dev-python/weasyprint
parentdb653baf275126269bb89ea0d2bdb8e50497a94c (diff)
gentoo auto-resync : 22:02:2025 - 00:16:22
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest2
-rw-r--r--dev-python/weasyprint/weasyprint-64.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 8f0bf388e2b4..8e57bc44d45a 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1,5 @@
DIST weasyprint-64.0.tar.gz 498075 BLAKE2B 572bac1f70476d63f8f40e3ace90e534bbe69c5a071bbe1e9de7bb8d1c5b06b150d9e7ad7261e74d0c6aeb740b9889608e22bf71b7e01e0d313a1dc546b58fe8 SHA512 46e65777804d53174bb3020b1418d19c0bf815667d020c40fb7de567439272df65d74ab941fdb37edc7f1d4f06430d3ebaa65f8ce13c887235e39c51cefb3930
+DIST weasyprint-64.1.tar.gz 498647 BLAKE2B cc8f6f3a25ea92839dc8dabd10a680d1c14aaf72db48ac264c8d3ea80acabd6ead6c220e6fef06177ca46546361648a964d62a75f38af45ce9c6de961ad409d3 SHA512 35f66b56f2f0c6f5f9d48c7fd1ff5c8dd87481c9172856e17c53455b973484711134b9ab3fe9239831d334ff62c69e5e8b810cd982b771a4b3579ba0175fd6d2
EBUILD weasyprint-64.0.ebuild 1054 BLAKE2B 0f13f2bf3f8399d106b4215581c8c39f9c2c64b6ed1534c1d6859083f098da6af89b54ac50967664a0c14fab895d4edaa9cfa9c819278e7fb8fdefd54b92a39f SHA512 bff69e061eb270a4fcadfd53dd7610a0e38f7ae57b4227f5def0dd9df1d526531309a09312cbf491da77e04dd5ac008b59c63342ec3e375e3d4ba8508e885b13
+EBUILD weasyprint-64.1.ebuild 1055 BLAKE2B ca8289b15255682b429bd7966e6df10f3e1e4d665d12e9676c00d4ee0789358bc2eee399a0c5122fe7daa35d67969cb343b6d139702bc4f3fe5b60719bec8a3c SHA512 d0cf55032ff827bd628b52878bf04d1a32b9521c5091678ae41b25059d047ff86e70aae421dde9d0fb94ed3f3b6808f64c4a4c41c0a76dc415c91622326b9720
MISC metadata.xml 382 BLAKE2B 3e5d142b055354e1ea440d9efd4bf92458b1da3f777dd90929ce2041ca6e0969fa6e58aacfb4a5a93ff90805e0d8ec4c9c6253559ca54698f5029639ce35ac8a SHA512 43415064a6f56eaca974031e51d63118d1c65b33e4399302fc72cc2cd6f15e0a47cf411b18d3c5136e866115855deb19b6a9e058a18049151959ce5ee29ececf
diff --git a/dev-python/weasyprint/weasyprint-64.1.ebuild b/dev-python/weasyprint/weasyprint-64.1.ebuild
new file mode 100644
index 000000000000..d62e3bc92379
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-64.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.1.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tinyhtml5-2.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}