summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-12 02:01:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-12 02:01:24 +0000
commit39c32f4d5dca9f6293fccb69e9d50baf494c8de4 (patch)
treeec772fdf23a7279a60e9063b01c2dc909741a197 /dev-python/weasyprint
parent494ca58c9f5243dd4b56557aa8c41bce76e95ec3 (diff)
gentoo auto-resync : 12:12:2024 - 02:01:23
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest2
-rw-r--r--dev-python/weasyprint/weasyprint-63.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index c766ec74dfbc..24dd477aa672 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1,5 @@
DIST weasyprint-63.0.tar.gz 491295 BLAKE2B f25a777a5057502f5a056417037411325c7600db2f1609c854c43ade98a1d7bda6a5c4663e7221e3b8002dfa763aff1b104541ee4cb55b0079cf973f256efe6d SHA512 79384ead532dbcfc561d2c490fbc04d7d0d11ed3c589fe375e9b2bb43e57a28c5bcfeaa7a6fb8daa1b031ce56720775e7b558c0a6ac5d195dee4310a3a3cab8d
+DIST weasyprint-63.1.tar.gz 491880 BLAKE2B 564c52abe3299aa2c51733c883c59ea0581953e067c003377cf0456412bd0cc49f38a03ea46f9cc6e3a3eb4c8df4daa1359996e0525bd9420b1720a26a393877 SHA512 1fda3126dd5c028b42515819f58153092d1607ea5a327a8668cd11ce44aa2b73d7340c04825ce80486881ac1b0dcfe789ffaec277f7a81465efc9067b9b9c87c
EBUILD weasyprint-63.0.ebuild 1163 BLAKE2B a3e8d718f22e780454df049193b33a38878ff731ee37492d8d0b7d926098771c2d3abe50ab7685bc156bbb0014fc681e41654cfcc39f9d8aa5fcf878a8079cee SHA512 4a891481afcf883ea6415960533a519139b813541c15cb0e65a4a21d0cfe7a10f826003f2ed7ac169860fdc4719206b10ed42fbac34ea4379a652fdf6021ea90
+EBUILD weasyprint-63.1.ebuild 1055 BLAKE2B 316c758c1ee3c9e62f2ce2d08bf77578adbc62ac4c5d43723df437132ef9542dd6e71de8ce99222c77a8f7ce5cf404fc0224a5e38ba45ac7e08b881fe356e1af SHA512 df941c5ef53f4886c7be48b9fb6ea68da8f609ea4aebd8dcef24182cbd10d63a38a12e054dc45a177a658dd6684aaf1303f262f17ca60f339170c8cf35f0224e
MISC metadata.xml 382 BLAKE2B 3e5d142b055354e1ea440d9efd4bf92458b1da3f777dd90929ce2041ca6e0969fa6e58aacfb4a5a93ff90805e0d8ec4c9c6253559ca54698f5029639ce35ac8a SHA512 43415064a6f56eaca974031e51d63118d1c65b33e4399302fc72cc2cd6f15e0a47cf411b18d3c5136e866115855deb19b6a9e058a18049151959ce5ee29ececf
diff --git a/dev-python/weasyprint/weasyprint-63.1.ebuild b/dev-python/weasyprint/weasyprint-63.1.ebuild
new file mode 100644
index 000000000000..70e4072abe54
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-63.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.1.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tinyhtml5-2.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}