summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint/weasyprint-51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/weasyprint/weasyprint-51.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/weasyprint/weasyprint-51.ebuild')
-rw-r--r--dev-python/weasyprint/weasyprint-51.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/weasyprint/weasyprint-51.ebuild b/dev-python/weasyprint/weasyprint-51.ebuild
index fdcc64deeca7..dde41858dcdb 100644
--- a/dev-python/weasyprint/weasyprint-51.ebuild
+++ b/dev-python/weasyprint/weasyprint-51.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..8} )
inherit distutils-r1
@@ -34,7 +35,7 @@ RDEPEND="
x11-libs/pango:0/0
"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]