summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint/weasyprint-51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/weasyprint/weasyprint-51.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/weasyprint/weasyprint-51.ebuild')
-rw-r--r--dev-python/weasyprint/weasyprint-51.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/weasyprint/weasyprint-51.ebuild b/dev-python/weasyprint/weasyprint-51.ebuild
new file mode 100644
index 000000000000..fdcc64deeca7
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-51.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg test tiff"
+RESTRICT="!test? ( test )"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+# >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/cairocffi-0.9[${PYTHON_USEDEP}]
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-2.4.0[${PYTHON_USEDEP}]
+ >=x11-libs/cairo-1.15.4
+ x11-libs/gdk-pixbuf[jpeg?,tiff?]
+ x11-libs/pango:0/0
+"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-51-skip-useless-deps.patch" )
+# "${FILESDIR}/${PN}-43-skip-failing-test.patch"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ pytest -vv || die "testsuite failed under ${EPYTHON}"
+}