summaryrefslogtreecommitdiff
path: root/dev-python/wcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/wcwidth
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest2
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild13
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index d94cff658514..7d2543299211 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1,3 +1,3 @@
DIST wcwidth-0.2.5.gh.tar.gz 47514 BLAKE2B 0ac5fb08283c23039453408da2edac36e2079fde8fc903002785e2e0f8bed55d1d6a291181097f73e4ec8152b6eaa4f4553b0b39fe1cadc7a99bacb2d7e55d2c SHA512 3f1f1fefd3ee9f06ea2051842e8c3bb09a92501f031124b8514bec444eaa8594ab9649534b4264340d475716d5a6571dbe5ae932f685160defd75c19295e60f9
-EBUILD wcwidth-0.2.5-r1.ebuild 908 BLAKE2B b481ec9e70c5004fbbd6f7e07167bc5fa7ea72fce9fb02164623dfb62b2372e40f6fcaddb665feab0e3c757f6604a492559f84bfe0457e8b7ee4a083550d4a49 SHA512 a80253e44b75885d83b7f98f9bdaf119410c335376cc1eb6610c04194f52b396f553842a2cdc1618d98c708cfe7cd6d2441406ddefac2b57f01d4e1f5d773b7f
+EBUILD wcwidth-0.2.5-r1.ebuild 1080 BLAKE2B 112369e788e7e6cf2a53f0d0f7b8a28da28ea6a7e125eb338b1cd2aafdf93ac53245f976448ec4afdbb687d02ebc9b7ed4c762ad6a2f2300783dbaee96602f7b SHA512 109aa6b9bcd75ded5366162a8a25f69dd036fe20aa5d9e46fa130900ced57a0719b84e3bcccb67f5201414ed53d97b5deb84ad8c7dd1fbf2109314724f8584a4
MISC metadata.xml 401 BLAKE2B 539430ada34933bd8bebc7146f9fc472a9a6e076cce36d6e34026d54464da99cc520e3a473f246c807531fa7edbefec87cde6cb948c8d295f77aae122466a608 SHA512 d416016c92307a1ae828e8135fac401dca0c005d4d0739874f6cb90ef9c36b9f41674896f30298826b200aaffad674c985ab7d06f76ac8897e9dfe1652aba426
diff --git a/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild b/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
index be8b8824c2f8..c4313c41c6fe 100644
--- a/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
+++ b/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -24,13 +24,20 @@ RDEPEND="
distutils_enable_tests pytest
-DOCS=()
-
src_prepare() {
sed -e 's:--cov-append::' \
-e 's:--cov-report=html::' \
-e 's:--cov=wcwidth::' \
-i tox.ini || die
sed -i -e 's:test_package_version:_&:' tests/test_core.py || die
+
+ # causes pytest to fail, bug 775077
+ sed -i '/^looponfailroots =/d' tox.ini || die
distutils-r1_src_prepare
}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}