summaryrefslogtreecommitdiff
path: root/dev-python/wcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 11:54:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 11:54:41 +0000
commit046c3c0984fd20387a9f86cdd0842fd81e70d94f (patch)
treecc10a34db3ff175a68ebd1f398672156c9aad0e9 /dev-python/wcwidth
parentbdc9b55c978e3939e16252e66e83950cbecbf77c (diff)
gentoo auto-resync : 15:01:2023 - 11:54:40
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest2
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.6.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index b0fc78fe432b..f593d217c464 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1,3 +1,5 @@
DIST wcwidth-0.2.5.gh.tar.gz 47514 BLAKE2B 0ac5fb08283c23039453408da2edac36e2079fde8fc903002785e2e0f8bed55d1d6a291181097f73e4ec8152b6eaa4f4553b0b39fe1cadc7a99bacb2d7e55d2c SHA512 3f1f1fefd3ee9f06ea2051842e8c3bb09a92501f031124b8514bec444eaa8594ab9649534b4264340d475716d5a6571dbe5ae932f685160defd75c19295e60f9
+DIST wcwidth-0.2.6.gh.tar.gz 51990 BLAKE2B 8561e06aaf92f48246bacfb4012358067d81d4d9eeb33a0406eb012b5c22841ac66ff5760df2d5ea6a5d48a1880b4b9cbbcddf7a5eba5f663f6a559005f657ad SHA512 1f97cb6ef6a804da1d062b8dafb146a3e21261e63a644bad88bed74101be1371c753c2645db5ad25868fe9641fce9b13bd5dc920496b00e1d73d406f69631ac9
EBUILD wcwidth-0.2.5-r1.ebuild 995 BLAKE2B 8ce789e26ba19903b520089f13de52920b255d2b77202bf0d9b2be6f11e92e6e6c850f991f6b2c1edccad4e66c4f3d462ed608d8b3fc30ed33439e484cf887d1 SHA512 9eb62216d2359d3587a3ccc579e29d1f157397bfc76ab80ca394b80470c24cd9b549719b02d568e064e363feaddfef95865939345d5c130e4767fd8d79ed4f92
+EBUILD wcwidth-0.2.6.ebuild 890 BLAKE2B 299d7e9a1f1bd8f80dfdc356afbc736875341d2bdca66f781b2aaedb259698c3b4142b46c332c1f3a032de55a3fc68f67e3f863329e65725650bbcb135db5785 SHA512 5418fdb39e63d8c166e763d70f07fa1a03d78447be9ce006e671bb9a92349ca31f498ddb200f8e005097ee25f64c197d32c37acdcfd6b4f9cf236f9165485298
MISC metadata.xml 402 BLAKE2B 86714d496f80fe46cb313bed026135b2712ddfb47fea5994d0021516aa6ad28eb5fc52d37b37a7a224ec0613681b27ee039f4ac734430d94aafe4ec8946cecc7 SHA512 85c0e684f66a5582ca63d6f72c4e69101e8ec30f8e03c52e972fa36a2e6b6d2a8f019fb33a1e39e73fb37de25c82b906b18ac626afdd0a93d97db2ddcf485063
diff --git a/dev-python/wcwidth/wcwidth-0.2.6.ebuild b/dev-python/wcwidth/wcwidth-0.2.6.ebuild
new file mode 100644
index 000000000000..a442e366ff6d
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="
+ https://pypi.org/project/wcwidth/
+ https://github.com/jquast/wcwidth/
+"
+SRC_URI="
+ https://github.com/jquast/wcwidth/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov-append::' \
+ -e 's:--cov-report=html::' \
+ -e 's:--cov=wcwidth::' \
+ -i tox.ini || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}