summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/wcmatch
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest4
-rw-r--r--dev-python/wcmatch/metadata.xml2
-rw-r--r--dev-python/wcmatch/wcmatch-8.2.ebuild57
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 2e99fad848d4..2be750e5eba1 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,3 +1,5 @@
DIST wcmatch-8.1.2.tar.gz 112726 BLAKE2B 4d91425f30e81f1ff3449b364b74f242b7393b7a4a162538e57406f9d5cc05d24277d6c0119c40266d4474c9c99919ade8d0450b1999abb39077ffc64f495719 SHA512 f96fc646db334407229ee9885b308eb2b27967d9b4e4245df33641605af678f3edfb54f53c5c8722b946029d39779fcd775299963530036c723cfa860dcfff38
+DIST wcmatch-8.2.tar.gz 113537 BLAKE2B d1fe53f7d2394af31750c0b98451749201b1adbd8d00a734418afd8e208a9480b913059f78f62016be2fc2109813406c096f8ab60973a716b6ca275377551281 SHA512 d56d868ec0578ae59eb5f39ff17005faed13162141e3ced15c60d8de5f8e8b1a16eaf66e7c73cffdbd288b94db57843112624de8e5b588d26a5e46d4edb72168
EBUILD wcmatch-8.1.2.ebuild 1443 BLAKE2B 8bfaf6f2402343b2adb91680c5b23d369326b62f88b27ddf0c289599bca11fd53f8bf6b2bd14ec75b192f0df4cb086d4d35e90e621b34f870644258d88055b49 SHA512 28ec3d2cd6093d6433faa32fefa1e3a0f549df3e1b28098a6dcaf90b6a7df2cbabb26f99459c95de4781cf04d08725afad1d950c39f08ee26516a6e37a0deb4c
-MISC metadata.xml 3040 BLAKE2B 9bb56694fe8fe1d9621e6eafe58c90242238fee0ffddb4f56fa2677bcd996ec94174998bee45164aaf797ed33c3e55f15c60b5b1dcf00dc10ddf35fb9ff33b31 SHA512 59cd3bdbc4859fe572e043e13efcb813b020be80ee1d6a7ef1b7d1020bbfa25cfc457b923e53ac0a4c4d0c33636d43f57a3cef73e9f3204d9f86851019ae0302
+EBUILD wcmatch-8.2.ebuild 1293 BLAKE2B b16a00ed341661f5623d87b8934e1bf3c6cd3c5bedb1b6c26bb8f4c6b657bc54197762700a8226d99c589c36672f12963d51e1b220dce97b501de3d461b0e8d7 SHA512 9ca84e9a8969094e7a51e90675645f9e14ad80482cbf13374eb06df97dc8282a42ab5d543ad787304c4637c1c188fc32d6a104448cabebadd9c91593bfaf7942
+MISC metadata.xml 3086 BLAKE2B 70a8843ac7d26d1ff596516cba4307a7e15ebf474997ee65edb44ba4d626b58ac75ba52158f90c471cb2b59bccb89eef22afedc0d6e18b8d6fef1faf1c361a36 SHA512 074dd8d50af976cb98853b05716adedb4abb848cce120f07967c17e7eeafadd3bc25f6cd1b71421aab80ee6652b72935677548b33ca2ffec7c18c79abd3a3ac2
diff --git a/dev-python/wcmatch/metadata.xml b/dev-python/wcmatch/metadata.xml
index 1890dab7aa7c..3dae50904c3f 100644
--- a/dev-python/wcmatch/metadata.xml
+++ b/dev-python/wcmatch/metadata.xml
@@ -15,6 +15,7 @@
</maintainer>
<maintainer type="project">
<email>python@gentoo.org</email>
+ <name>Python</name>
</maintainer>
<upstream>
<remote-id type="github">facelessuser/wcmatch</remote-id>
@@ -51,4 +52,5 @@ Features:
Provides an alternative file crawler called wcmatch.
And more...
</longdescription>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/dev-python/wcmatch/wcmatch-8.2.ebuild b/dev-python/wcmatch/wcmatch-8.2.ebuild
new file mode 100644
index 000000000000..780c9e32404b
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
+ >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}