summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/wcmatch
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest2
-rw-r--r--dev-python/wcmatch/wcmatch-9.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 451a0e0b24ab..e99a949db23c 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,3 +1,5 @@
DIST wcmatch-8.5.2.gh.tar.gz 117532 BLAKE2B f01ce989d1580da6575535a3c025aa50defe779ca723359dab379dda1c4c98d812343773d0130c56f8ebf74dae4472caa188b4b7b323f2df09686ebba297fa9a SHA512 1a79940bc54996f587dda6aacefee212adb4d527be68cc7b762e7e16c0796ebd833bdeb5abe6f48fa3d6d82f720ade054633ce28ee506b17c4d89cccffaa8e70
+DIST wcmatch-9.0.gh.tar.gz 116090 BLAKE2B 6d33886a9f1f0f53c95dcd8adcebffcd50075c54f8a6398d22e372b811dab33a09152c98d982ed817c9230ae0f200e74dac209da785979365aa38a511b790965 SHA512 638a59b70729eeb39a9bc059d08271b8cfe924a9fce4317718b3cc38e057f1176ec87b033f9f30494fce5c1d24560ef22cd0d9e2a4df12c2b765c3e1358756d6
EBUILD wcmatch-8.5.2.ebuild 1290 BLAKE2B d9ec071df4f7f83765ba105eb30990d9d3df3e9a21a5d757bd25e0bd22a38f619b552d11d338fa69c048f40913c684b91e9c2aa4b03d78c1cfd5134dbfb67c1c SHA512 91bf07d5ccba9ba6d0d03d2316b130f1698bf25fd0cf921728aaccd27eedb0f29360a26186c1d773b0fe5c97ae269cb6ae2fcb0f711593f7e7fd569265f39c7e
+EBUILD wcmatch-9.0.ebuild 1293 BLAKE2B 6e039f322ecb83199cbf6ac98a3c454c0d289eb89913333f1a9281caac0c034574b0a4a0bfec4c3b5608ba9458bcb01596df80fbc7464956453fe773fbaacb50 SHA512 e5096ccb23ae208ad20b85e2eaccb02cef6a5ef14a708a7924ff0ecbdb8fa599f1c90f6dde8711d14950a777a6be06bbc0b0501192f228d057ad70ba5d3629cc
MISC metadata.xml 2701 BLAKE2B f09d6810f516ce43944ef492b90cd8adf15beae1eba1a0deb65a9def3582e674c18a75827166661333e9bd1732e757743b03a3379d6d4bc7bf5e2195434ac5bc SHA512 d8c4a11a7602b559976fb777ce862070b6e273e64e6a22842b22c9917bacfe1aed5dc199c7c01ec4f16e57d30c7fc2bc2d2d3e91379059ea305930aef8fb3189
diff --git a/dev-python/wcmatch/wcmatch-9.0.ebuild b/dev-python/wcmatch/wcmatch-9.0.ebuild
new file mode 100644
index 000000000000..31f842037d84
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-9.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}