summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 05:40:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 05:40:28 +0000
commitb08574f4102ea8282627f075758d981eb4ba6c56 (patch)
treee9089d8d349367b6fec26823430ba5754a23e558 /dev-python/wcmatch
parent3fe8d2707d7ce24cce8f5d7eaa16b0b68cbaa2a4 (diff)
gentoo auto-resync : 21:02:2024 - 05:40:28
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest2
-rw-r--r--dev-python/wcmatch/wcmatch-8.5.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index e2add18fc33f..cfc082c40d88 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,3 +1,5 @@
+DIST wcmatch-8.5.1.gh.tar.gz 117483 BLAKE2B db4d77651ab4fc6692c746d94dda68dc0fcdfe72a6e3b512b4f60a1bd5bf7015e21349d022c6ec17ea2bbc55ae87cf6c9a3690d9b6774f02a167b4b0ad65b691 SHA512 10ab7d76ad7c71efb2639e2d439593a45339f485f1f628770ae845c291c34d0e3fc8a9b75b6ce6d3c131c1f0a521f3aafcadc7d24ffad5284e9db06dc5838974
DIST wcmatch-8.5.gh.tar.gz 117301 BLAKE2B db62057e9fe148d64a7b326ba15029a20781008288a60171793db3e4e3aab75ca4eeb1be63b7c2af5951225d512d4a5886982cb278c703980b755e6b816e51bf SHA512 a4de7714945e36e0ac68c5ce99cc06887fdceb3a461464ceb05e66f5a84965cafa9cdac337e3332f5fe42aaef90d53978185e451b28d56730418ca830f98c290
+EBUILD wcmatch-8.5.1.ebuild 1293 BLAKE2B 8042a7a4741af68146b22080fb0f4a6aa4b06705d64861163df918c304df63c49fd4be63f75d65d0dadd18c91d119664c59d25085ff383b6120e57cd798ce4a6 SHA512 9d5b286814409285e611b93aafe2f4e47527a9a882cde2cb9759b1b5ffc2b23950af436fb78d9bc08ed2a1fcf623ab746e5098a93e2f074147fc86c20e9d04a6
EBUILD wcmatch-8.5.ebuild 1290 BLAKE2B f65259e229c54ed48aaee86e4807965e105fe50014bee71eac19c31c513118002aad2898f4c25da408712d85f671feb0da3676eedcfa7bf8e775899719189657 SHA512 cfb37a1b9e66e284d6ff7b3efba23af660eeb879abdc43d895f806f14aab2526c4097f9f8d068cb020ee50957fcd608926cd7d1c7b0199e18d7abf82ae8e8a85
MISC metadata.xml 2968 BLAKE2B c3164dbe165e67cd2cbd891bb6d1468c1382ab1a72ea59ab1eacc6999c8f0fa2718c30eb83f755b3d520ab22a40bb6f2997704b4e2a1aa23717aa05a7eea4526 SHA512 49ccfdde6bf3137386e4053e8306d1792b173b8d71f05789e20e24d61ea1e6ddd0b3a1d0aedf54790bb43fe2d9de4844d79ab98424abe13dda466b9990a3a592
diff --git a/dev-python/wcmatch/wcmatch-8.5.1.ebuild b/dev-python/wcmatch/wcmatch-8.5.1.ebuild
new file mode 100644
index 000000000000..67f86264c16d
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.5.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}