summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/wcmatch
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest3
-rw-r--r--dev-python/wcmatch/metadata.xml52
-rw-r--r--dev-python/wcmatch/wcmatch-7.1.ebuild56
3 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
new file mode 100644
index 000000000000..1474a52d2d05
--- /dev/null
+++ b/dev-python/wcmatch/Manifest
@@ -0,0 +1,3 @@
+DIST wcmatch-7.1.tar.gz 105744 BLAKE2B 0add1c68025c92ac57d6ea64d82bddb20bace60de5d319fb16e16802f208d788d876695bfcd186b80630039f544565c631d36e1c7327dee5d8c799eff8c80ce2 SHA512 79d62d85f13d245e38d0fe92a275e24058b86af8aaf9a926bfd950dad4ec47e40e763c18b08d3eb4ddd925832ae9910f13407094070442b41dbe2fe4ad11fb39
+EBUILD wcmatch-7.1.ebuild 1282 BLAKE2B b20d13b6cb341a90220bf601da53c5988e8bcb8f343236140b86e32b8bdf5d53b69b289f4a944b9544a5f950e9d285cb445c5d039f9b7bac4c16013eb6f69978 SHA512 a6e4a2b56a383e50ce8ac772e8db214da0a8e76bd420ad61b58cea1e624c429a73d010ca1400867fa2c8652c3636d0d02103468feb23e0d265be938507dc6e0e
+MISC metadata.xml 2929 BLAKE2B cd54289196c1541b0d4e57a1e342cfc7f06eb4acea5192390a9ff5b6cab54822678d4b6740e5c023db55909422ccc17ee925d4b889f210afce81ae40b77f7bce SHA512 ebe1f7a9a12be8c19797e830ba3429cfd03fb5983dbcab07851c6857d0dbcc59d3a02d8d57da2d6940a20bca2b2e3041e7e014fe45f97eebee4ac923d8114a90
diff --git a/dev-python/wcmatch/metadata.xml b/dev-python/wcmatch/metadata.xml
new file mode 100644
index 000000000000..a6af55c38820
--- /dev/null
+++ b/dev-python/wcmatch/metadata.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facelessuser/wcmatch</remote-id>
+ <remote-id type="pypi">wcmatch</remote-id>
+ </upstream>
+ <longdescription lang="en">
+Wildcard Match provides an enhanced fnmatch, glob, and pathlib library in order to provide
+file matching and globbing that more closely follows the features found in Bash. In some
+ways these libraries are similar to Python's builtin libraries as they provide a similar
+interface to match, filter, and glob the file system. But they also include a number of
+features found in Bash's globbing such as backslash escaping, brace expansion, extended
+glob pattern groups, etc. They also add a number of new useful functions as well, such as
+globmatch which functions like fnmatch, but for paths.
+Wildcard Match also adds a file search utility called wcmatch that is built on top of fnmatch and globmatch. It was
+originally written for Rummage, but split out into this project to be used by other
+projects that may find its approach useful.
+Bash is used as a guide when making decisions on behavior for fnmatch and glob. Behavior may differ from Bash version to Bash version,
+but an attempt is made to keep Wildcard Match up with the latest relevant changes. With
+all of this said, there may be a few corner cases in which we've intentionally chosen to
+not exactly mirror Bash. If an issue is found where Wildcard Match seems to deviate in an
+illogical way, we'd love to hear about it in the issue tracker.
+Features
+A quick overview of Wildcard Match's
+Features:
+ Provides an interface comparable to Python's builtin in fnamtch, glob, and pathlib.
+ Allows for a much more configurable experience when matching or globbing with many more features. Adds support for ** in glob.
+ Adds support for escaping characters with \.
+ Add support for POSIX style character classes inside sequences: [[:alnum:]], etc. The C locale is used for byte strings and Unicode properties for Unicode strings.
+ Adds support for brace expansion: a{b,{c,d}} --> ab ac ad.
+ Adds support for expanding ~ or ~username to the appropriate user path.
+ Adds support for extended match patterns: @(...), +(...), *(...), ?(...), and !(...).
+ Adds ability to match path names via the path centric globmatch.
+ Provides a pathlib variant that uses Wildcard Match's glob library instead of Python's default.
+ Provides an alternative file crawler called wcmatch.
+ And more...
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/wcmatch/wcmatch-7.1.ebuild b/dev-python/wcmatch/wcmatch-7.1.ebuild
new file mode 100644
index 000000000000..4fc94a4a4728
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-7.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch
+ https://pypi.org/project/wcmatch"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
+ >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+)"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # no such file or dir ~homedir
+ sed -i -e 's:test_tilde_user:_&:' \
+ tests/test_glob.py || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}