summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/wcmatch
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest2
-rw-r--r--dev-python/wcmatch/wcmatch-8.1.2.ebuild61
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 2590dbc6b8fe..0e6a7a06cf0a 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,5 +1,3 @@
-DIST wcmatch-8.1.2.tar.gz 112726 BLAKE2B 4d91425f30e81f1ff3449b364b74f242b7393b7a4a162538e57406f9d5cc05d24277d6c0119c40266d4474c9c99919ade8d0450b1999abb39077ffc64f495719 SHA512 f96fc646db334407229ee9885b308eb2b27967d9b4e4245df33641605af678f3edfb54f53c5c8722b946029d39779fcd775299963530036c723cfa860dcfff38
DIST wcmatch-8.2.tar.gz 113537 BLAKE2B d1fe53f7d2394af31750c0b98451749201b1adbd8d00a734418afd8e208a9480b913059f78f62016be2fc2109813406c096f8ab60973a716b6ca275377551281 SHA512 d56d868ec0578ae59eb5f39ff17005faed13162141e3ced15c60d8de5f8e8b1a16eaf66e7c73cffdbd288b94db57843112624de8e5b588d26a5e46d4edb72168
-EBUILD wcmatch-8.1.2.ebuild 1443 BLAKE2B 8bfaf6f2402343b2adb91680c5b23d369326b62f88b27ddf0c289599bca11fd53f8bf6b2bd14ec75b192f0df4cb086d4d35e90e621b34f870644258d88055b49 SHA512 28ec3d2cd6093d6433faa32fefa1e3a0f549df3e1b28098a6dcaf90b6a7df2cbabb26f99459c95de4781cf04d08725afad1d950c39f08ee26516a6e37a0deb4c
EBUILD wcmatch-8.2.ebuild 1298 BLAKE2B a407e9dc3878ce0d0ee1b14600156b77d5a04de131d21cde63f5761601d9432f2f8e5db3e4a9809b7a429d168df6ea7cbb27656d73ffe0e544cd460315acfd10 SHA512 9435d1e43aa0608eef47e96add8dcd8f45b5c52303ab3eb58e8ba7eeebc27fdc92909a1c08684013715594c1167c9a3391526d729bee951aa2d2b0d6f2881a01
MISC metadata.xml 3087 BLAKE2B c15652b6011b559ecaddfa76231050204a857839e3520dd77a626580d753225389f4484e22aadcd58e0e61558836655ae29adc01349484774b27142bd633a9b8 SHA512 68361ca29cbebb9a9fc9a456d485b64796b0fffc09201ff1c09e7ed913526923dca179c7e21b0420e50a55e53ab3bd01e6ecea204b38995c81cff36c49059f16
diff --git a/dev-python/wcmatch/wcmatch-8.1.2.ebuild b/dev-python/wcmatch/wcmatch-8.1.2.ebuild
deleted file mode 100644
index fdc416d52454..000000000000
--- a/dev-python/wcmatch/wcmatch-8.1.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="
- ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
- dev-python/mkdocs-material
- dev-python/mkdocs-git-revision-date-localized-plugin
- dev-python/mkdocs-minify-plugin
- dev-python/pyspelling
-"
-
-inherit distutils-r1 docs
-
-DESCRIPTION="Wildcard/glob file name matcher"
-HOMEPAGE="
- https://github.com/facelessuser/wcmatch/
- https://pypi.org/project/wcmatch/"
-SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
- >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
-"
-
-BDEPEND="test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-vcs/git
-)"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # this test makes a really wrong assumption that basename of $HOME
- # will be a username
- sed -i -e 's:test_tilde_user:_&:' \
- tests/test_glob.py || die
-
- # tests require some files in homedir
- > "${HOME}"/test1.txt || die
- > "${HOME}"/test2.txt || die
-
- # mkdocs-git-revision-date-localized-plugin needs git repo
- if use doc; then
- git init || die
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git add . || die
- git commit -m 'init' || die
- fi
-
- distutils-r1_python_prepare_all
-}