summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/wcmatch
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest2
-rw-r--r--dev-python/wcmatch/wcmatch-8.5.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 778e77cf0f8c..f9d013c73e35 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,3 +1,5 @@
DIST wcmatch-8.4.1.gh.tar.gz 117065 BLAKE2B 6528170503507aa9742a0e0878f7cfe2586408471acde82ffbf1011fbf48cbed6a45d580436cb6a63a54a81d1c237544a48112eb4c06f923752eb09521d7f8a5 SHA512 6bc8d59b678a40e28eee7816f3b447fe3396f52e982df8e0b5e26472b4ffd1342f58edc41850386954783e6d07f1d66d9372cc1495f048b9a542b572b1d8e20f
+DIST wcmatch-8.5.gh.tar.gz 117301 BLAKE2B db62057e9fe148d64a7b326ba15029a20781008288a60171793db3e4e3aab75ca4eeb1be63b7c2af5951225d512d4a5886982cb278c703980b755e6b816e51bf SHA512 a4de7714945e36e0ac68c5ce99cc06887fdceb3a461464ceb05e66f5a84965cafa9cdac337e3332f5fe42aaef90d53978185e451b28d56730418ca830f98c290
EBUILD wcmatch-8.4.1.ebuild 1290 BLAKE2B 746b18cca045c2016f0f31c402761613850d0a120f1e70b71df3980e585457694154ccbeb628cf77144319b69c9e2393ca03cacd72c2e9cdb71135b767bcf307 SHA512 549771ad666c0aa8b5dc663beb0d1fe28686f477ccb9b07ca2cc8e412bbed2b218f1f2a7164ba19b830b993046f104fe944915565773a00807b8f2f12a6840fa
+EBUILD wcmatch-8.5.ebuild 1293 BLAKE2B c6b214d7a6850ba90b39bb98681f95d97c9ac6e1d258232a0bf0c840a759792b09c0f075360df38ad14a6a198f7830bca62dde07ee18e9195cdf2d8c381db6e7 SHA512 de8ec9642cac7f57b8e3311a5aaaadb3e3e85ac2c57931d9456fba304f8cd432d4d8547842e1874c9d29e7870aaff30168e805904a1b045903020d208e85007c
MISC metadata.xml 2968 BLAKE2B c3164dbe165e67cd2cbd891bb6d1468c1382ab1a72ea59ab1eacc6999c8f0fa2718c30eb83f755b3d520ab22a40bb6f2997704b4e2a1aa23717aa05a7eea4526 SHA512 49ccfdde6bf3137386e4053e8306d1792b173b8d71f05789e20e24d61ea1e6ddd0b3a1d0aedf54790bb43fe2d9de4844d79ab98424abe13dda466b9990a3a592
diff --git a/dev-python/wcmatch/wcmatch-8.5.ebuild b/dev-python/wcmatch/wcmatch-8.5.ebuild
new file mode 100644
index 000000000000..71f39ff5caa7
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}