summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/wcmatch
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest4
-rw-r--r--dev-python/wcmatch/metadata.xml3
-rw-r--r--dev-python/wcmatch/wcmatch-7.2.ebuild61
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 1474a52d2d05..7a8d662f6054 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,3 +1,5 @@
DIST wcmatch-7.1.tar.gz 105744 BLAKE2B 0add1c68025c92ac57d6ea64d82bddb20bace60de5d319fb16e16802f208d788d876695bfcd186b80630039f544565c631d36e1c7327dee5d8c799eff8c80ce2 SHA512 79d62d85f13d245e38d0fe92a275e24058b86af8aaf9a926bfd950dad4ec47e40e763c18b08d3eb4ddd925832ae9910f13407094070442b41dbe2fe4ad11fb39
+DIST wcmatch-7.2.tar.gz 105087 BLAKE2B a28bd9d02468f3ca83d606ee7f7d5c9b6b8883cf6e0c04b711765aefafce189f7f524a490c6831a739b579be66af5f4b1c7b6373da22e170211e611677c5788f SHA512 6fdc0a3cb6d66b323c509a5ee34c1e8df9a46a93fd1fc0921dfdbc17ac604934fdad3df5e8f253aa6a880bea2e81bb26ec097b9503c920433c5827ea91b327d8
EBUILD wcmatch-7.1.ebuild 1282 BLAKE2B b20d13b6cb341a90220bf601da53c5988e8bcb8f343236140b86e32b8bdf5d53b69b289f4a944b9544a5f950e9d285cb445c5d039f9b7bac4c16013eb6f69978 SHA512 a6e4a2b56a383e50ce8ac772e8db214da0a8e76bd420ad61b58cea1e624c429a73d010ca1400867fa2c8652c3636d0d02103468feb23e0d265be938507dc6e0e
-MISC metadata.xml 2929 BLAKE2B cd54289196c1541b0d4e57a1e342cfc7f06eb4acea5192390a9ff5b6cab54822678d4b6740e5c023db55909422ccc17ee925d4b889f210afce81ae40b77f7bce SHA512 ebe1f7a9a12be8c19797e830ba3429cfd03fb5983dbcab07851c6857d0dbcc59d3a02d8d57da2d6940a20bca2b2e3041e7e014fe45f97eebee4ac923d8114a90
+EBUILD wcmatch-7.2.ebuild 1443 BLAKE2B 8bfaf6f2402343b2adb91680c5b23d369326b62f88b27ddf0c289599bca11fd53f8bf6b2bd14ec75b192f0df4cb086d4d35e90e621b34f870644258d88055b49 SHA512 28ec3d2cd6093d6433faa32fefa1e3a0f549df3e1b28098a6dcaf90b6a7df2cbabb26f99459c95de4781cf04d08725afad1d950c39f08ee26516a6e37a0deb4c
+MISC metadata.xml 3008 BLAKE2B d7abc1a9ca8152f4e70c187503e1cd05181cb1d67343c5e2d62112e35171b0b528444f2b13ae8f2a0e86f29837795915b20f465fd286961decccc22052eea1f4 SHA512 331e3a2470fdeb5d88e92e8c2461c5253bf09084c5875d458ec0aa5263bc19240dcf3fdc85530c621d09e9498c5dc5d1a4ee47abde709edb6b51bbfeb50df29c
diff --git a/dev-python/wcmatch/metadata.xml b/dev-python/wcmatch/metadata.xml
index a6af55c38820..5e9ad1b81332 100644
--- a/dev-python/wcmatch/metadata.xml
+++ b/dev-python/wcmatch/metadata.xml
@@ -14,6 +14,9 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
<upstream>
<remote-id type="github">facelessuser/wcmatch</remote-id>
<remote-id type="pypi">wcmatch</remote-id>
diff --git a/dev-python/wcmatch/wcmatch-7.2.ebuild b/dev-python/wcmatch/wcmatch-7.2.ebuild
new file mode 100644
index 000000000000..fdc416d52454
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-7.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
+ >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+)"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # this test makes a really wrong assumption that basename of $HOME
+ # will be a username
+ sed -i -e 's:test_tilde_user:_&:' \
+ tests/test_glob.py || die
+
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}