summaryrefslogtreecommitdiff
path: root/dev-python/wcmatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/wcmatch
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest4
-rw-r--r--dev-python/wcmatch/wcmatch-8.3.ebuild3
-rw-r--r--dev-python/wcmatch/wcmatch-8.4.ebuild61
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index b56ff8cb7245..fec8f689490c 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1,3 +1,5 @@
DIST wcmatch-8.3.tar.gz 116600 BLAKE2B 8576a546278a69ba46af262bc925370e6d8b1828975d54fe3fe1a2e39fc8456134c7f7986e1674883ca0f0298c223be7efc67c7296a29d9a4f1b64e42614ce17 SHA512 64cd84e69ceb6c5953f281711d026540ac198256cda3ca32c90d2acb01b18c93ceaebd3440b395c3e77fc7ec38f350821b0095518ab5c065e698cfe0f2df4c1b
-EBUILD wcmatch-8.3.ebuild 1298 BLAKE2B be2d3367c2123854c41eb251a53a2cb0adbdb92546c0796df93571a0be702f8323a727d8ff67d6efeb33aac3d585f24b3e72e2290b5ea68f5a530f7141f27da3 SHA512 3ec7ba1eaf35a80a709af752edfd64275021e540324574876ba21b3c80486580c1cd0393c0c13df5b544fdc67a57cd0c74d957e9d50fbd3e303fe61f7a3ddd79
+DIST wcmatch-8.4.gh.tar.gz 116596 BLAKE2B cdfbc243fa62f4854490510a563163f99dac09eed16248fa7a72d0a2a7b96484fab4edf3ba497e96a46dca1f734b9c1b098da4d71784775f51b48fcfa5b8a24c SHA512 92478a769be129f9997ef75a384b9978d0647bbd7f2212aa058f1438e698a0a77d069871daf20889455f6e9bb73266d4e312f29f61c704a708fa48fa565d7614
+EBUILD wcmatch-8.3.ebuild 1330 BLAKE2B b05d8e357c50748e0402df20cefce7b03ecdcc5ddf5fd785b31587fecf067d62614508b5b7a13a79de886e2f86fa12c2cd7c3f1522458dc3dbf6a034fabf6eb7 SHA512 32e2997af18b5328353018dbcdd67b9039ecc9186575c4cf28e9155686d157b4b3238a2c471663b69275af2e5c9cd2acb3e4e74f13d981370c3ba804b886ccfd
+EBUILD wcmatch-8.4.ebuild 1263 BLAKE2B 2125764d0c698c86ce21fb7ad8e22bdacf4d346985cb72deb067d51e62b8f3baadab6a779ba480a2174d4f4c75dc0c281e2d13734a14c117a889cb8d623f303e SHA512 89ee0906631c1f604c81f78cd7cefbe3729ce6d9cac401dd8458073060268358b9ab0256c4c70b08eea5d9794705a9088f55f35d3e351452afd855f7c2bc28c6
MISC metadata.xml 3087 BLAKE2B c15652b6011b559ecaddfa76231050204a857839e3520dd77a626580d753225389f4484e22aadcd58e0e61558836655ae29adc01349484774b27142bd633a9b8 SHA512 68361ca29cbebb9a9fc9a456d485b64796b0fffc09201ff1c09e7ed913526923dca179c7e21b0420e50a55e53ab3bd01e6ecea204b38995c81cff36c49059f16
diff --git a/dev-python/wcmatch/wcmatch-8.3.ebuild b/dev-python/wcmatch/wcmatch-8.3.ebuild
index 8a9fe29ef3f2..7648775293cb 100644
--- a/dev-python/wcmatch/wcmatch-8.3.ebuild
+++ b/dev-python/wcmatch/wcmatch-8.3.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
DOCS_BUILDER="mkdocs"
DOCS_DEPEND="
diff --git a/dev-python/wcmatch/wcmatch-8.4.ebuild b/dev-python/wcmatch/wcmatch-8.4.ebuild
new file mode 100644
index 000000000000..c5bddee62f3a
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs_pymdownx_material_extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}