summaryrefslogtreecommitdiff
path: root/dev-python/wcag-contrast-ratio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/wcag-contrast-ratio
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/wcag-contrast-ratio')
-rw-r--r--dev-python/wcag-contrast-ratio/Manifest3
-rw-r--r--dev-python/wcag-contrast-ratio/metadata.xml13
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild31
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/wcag-contrast-ratio/Manifest b/dev-python/wcag-contrast-ratio/Manifest
new file mode 100644
index 000000000000..39c084b9a5ea
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/Manifest
@@ -0,0 +1,3 @@
+DIST wcag-contrast-ratio-0.9.gh.tar.gz 3347 BLAKE2B c32765e7011faf9128bd4c53673c4663b972e225e0f7249dd1b9f07b4184ae9ca93116f31de6a0538f04612a72ee1e805b37e1070ae62347508f29df2bbf9ec4 SHA512 70ff827b092cec884ba7e969deb8b5de944844b8d5536669f2c607061fbf569c217cec93268215deb9fdebc041efd992ed0cc89e0da013f9a1be8eeeb420cec5
+EBUILD wcag-contrast-ratio-0.9.ebuild 715 BLAKE2B 586c0393b2f485bfcfc4d9e30042a5698a5b87dd44a7507d5a81744e86619dcd7c4fc73fb7fda9e49fffb280f7b6ae0730a1a9a76beacb313baf5e4ab75ae674 SHA512 659865d13abf08c67ec6cdca57a616961989d1e9d525e30c01d7e69acc6ccefb066e9ea84dd0365518620037dcc9ca0e2ce334bc351e53533a066b6c7051bc57
+MISC metadata.xml 416 BLAKE2B 5363613fc828bc1398b25b81947464f6c71a2d972914b14744da29c723493843fd0d949b0070c5af3d67428694b7c7a2b0a40c8884a62e56d9caf3fa8882ed42 SHA512 c416ea13e371d17d90bb2c1362119431eb0241dc89d0be5c003e92604c66125b7a66e5648a179d1c166b2a4e3a990be86e502da621ebca8e7ba560f1b0558f58
diff --git a/dev-python/wcag-contrast-ratio/metadata.xml b/dev-python/wcag-contrast-ratio/metadata.xml
new file mode 100644
index 000000000000..6c547f086dfc
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">wcag-contrast-ratio</remote-id>
+ <remote-id type="github">gsnedders/wcag-contrast-ratio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
new file mode 100644
index 000000000000..830d26ee8aaf
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for computing contrast ratios, as required by WCAG 2.0"
+HOMEPAGE="
+ https://github.com/gsnedders/wcag-contrast-ratio/
+ https://pypi.org/project/wcag-contrast-ratio/"
+SRC_URI="
+ https://github.com/gsnedders/wcag-contrast-ratio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}