summaryrefslogtreecommitdiff
path: root/dev-python/watchgod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/watchgod
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/watchgod')
-rw-r--r--dev-python/watchgod/Manifest3
-rw-r--r--dev-python/watchgod/metadata.xml11
-rw-r--r--dev-python/watchgod/watchgod-0.7.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
new file mode 100644
index 000000000000..d4d37f4e1769
--- /dev/null
+++ b/dev-python/watchgod/Manifest
@@ -0,0 +1,3 @@
+DIST watchgod-0.7.gh.tar.gz 14362 BLAKE2B 0c16b7ef2a7e1d0ca2c9d27b1503a9710662364318d5021e916aabf90c8f917b0bf69559a545658f839953832edc579b0014a0736b3b155f097d1d29c2e4b4f7 SHA512 afa225b30cf796ce95861c61fbe8eb22ed72011522de53d53c41148311793db10e41b66e9eb1237c4372f142edaec992de79715c568e435ddb1695666be1cdd8
+EBUILD watchgod-0.7.ebuild 657 BLAKE2B f2da1475b5774ff4b5030ca31e23365760dc475d5fb09afd6692c6bf6e4942d92875fcaf11e086b0f13bb5f47b14fe76ff1d5408662039ef1d805d650d9503f2 SHA512 4b90656881e80a52beea3d1c0bf5c459927872115d5299902ed98de839817abdd0ef7923ba2521208d84230fa7b2163d822e2dd1f2ab672f673f12e27be7c232
+MISC metadata.xml 350 BLAKE2B a13e5a3a9299cb914851645a4ba2a3c5c63b7c55a478fb2b73472355a3b126c0fb82d7c1f21e61f44ef698bc19f2c351e29114d26afee9459069174ea1e53255 SHA512 a7b7f0f64ed2ffc26479e0f82b2ef30f29cd2cc71b38768478309aa61031dbb76e63528d03f136256e96d81469336e40999244c3ff0cef1e480102f298f582d3
diff --git a/dev-python/watchgod/metadata.xml b/dev-python/watchgod/metadata.xml
new file mode 100644
index 000000000000..37627d68f75d
--- /dev/null
+++ b/dev-python/watchgod/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samuelcolvin/watchgod</remote-id>
+ <remote-id type="pypi">watchgod</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/watchgod/watchgod-0.7.ebuild b/dev-python/watchgod/watchgod-0.7.ebuild
new file mode 100644
index 000000000000..66b254733fc1
--- /dev/null
+++ b/dev-python/watchgod/watchgod-0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Simple, modern file watching and code reload in Python"
+HOMEPAGE="
+ https://pypi.org/project/watchgod/
+ https://github.com/samuelcolvin/watchgod/"
+SRC_URI="
+ https://github.com/samuelcolvin/watchgod/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-toolbox[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest