summaryrefslogtreecommitdiff
path: root/dev-python/watchdog/watchdog-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 22:03:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 22:03:23 +0100
commited6e9ebb6ab4abd792d5b15e97ec245603dd6e2d (patch)
treee1f5f93f2986a4038351e6cf4804eb0c2aad060d /dev-python/watchdog/watchdog-2.3.0.ebuild
parent8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (diff)
gentoo auto-resync : 30:03:2023 - 22:03:23
Diffstat (limited to 'dev-python/watchdog/watchdog-2.3.0.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-2.3.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/watchdog/watchdog-2.3.0.ebuild b/dev-python/watchdog/watchdog-2.3.0.ebuild
deleted file mode 100644
index 10eca6827871..000000000000
--- a/dev-python/watchdog/watchdog-2.3.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="
- https://github.com/gorakhargosh/watchdog/
- https://pypi.org/project/watchdog/
-"
-SRC_URI="
- https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- default
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires root powers via sudo (yes, seriously)
- tests/test_inotify_buffer.py::test_unmount_watched_directory_filesystem
- )
-
- epytest -p no:django
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}