summaryrefslogtreecommitdiff
path: root/dev-python/watchdog/watchdog-2.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/watchdog/watchdog-2.1.5.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/watchdog/watchdog-2.1.5.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-2.1.5.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/watchdog/watchdog-2.1.5.ebuild b/dev-python/watchdog/watchdog-2.1.5.ebuild
deleted file mode 100644
index 4e7831b4677f..000000000000
--- a/dev-python/watchdog/watchdog-2.1.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="https://github.com/gorakhargosh/watchdog"
-SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- dev-python/argh[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- default
-}
-
-python_test() {
- local deselect=()
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- tests/test_inotify_buffer.py::test_move_internal_batch
- )
-
- epytest -p no:django ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}