summaryrefslogtreecommitdiff
path: root/dev-python/watchdog/watchdog-2.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/watchdog/watchdog-2.1.4.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/watchdog/watchdog-2.1.4.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-2.1.4.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/watchdog/watchdog-2.1.4.ebuild b/dev-python/watchdog/watchdog-2.1.4.ebuild
deleted file mode 100644
index 7b9fe168c229..000000000000
--- a/dev-python/watchdog/watchdog-2.1.4.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="https://github.com/gorakhargosh/watchdog"
-SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- dev-python/argh[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- default
-}
-
-python_test() {
- local deselect=()
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- tests/test_inotify_buffer.py::test_move_internal_batch
- )
-
- epytest -p no:django ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}