summaryrefslogtreecommitdiff
path: root/dev-python/warlock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/warlock
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/warlock')
-rw-r--r--dev-python/warlock/Manifest3
-rw-r--r--dev-python/warlock/warlock-1.3.3-r1.ebuild (renamed from dev-python/warlock/warlock-1.3.3.ebuild)12
-rw-r--r--dev-python/warlock/warlock-1.3.3-r2.ebuild36
3 files changed, 47 insertions, 4 deletions
diff --git a/dev-python/warlock/Manifest b/dev-python/warlock/Manifest
index 520cc1245b2f..99276b2a8f39 100644
--- a/dev-python/warlock/Manifest
+++ b/dev-python/warlock/Manifest
@@ -1,3 +1,4 @@
DIST warlock-1.3.3.gh.tar.gz 11147 BLAKE2B 1281348076500315c5aa105691b8e5a50ccf2ba79335fb8581a0b89bfc96bb3076a797c4ebe011f6c347667a0971bbbdd2b1bf413d0692ae5977216c524cbee0 SHA512 8a9135a17ccc0d0939ad98eee16100ec68b911d672b3af549f7629edcd6e08129f9e4ab707082593274fc896bc405ab6d6ba9e4bf6fc40b8522ec99327c983ec
-EBUILD warlock-1.3.3.ebuild 716 BLAKE2B ec054b9474d7a7c4119fc91a3028db1f301079380b9151d4aa77e832b4f59b5b8f31a31263432f0d928b11b538b5b316623ced48f5bfafb6439e770c960e7443 SHA512 0ec6dd80db83343dc015961a9a43594b7947ce10805e2869b50047170c14edea0398cd4fff77b8ce01e0a2365726b1d74c5122b42fabf1d1584f903b8df3050e
+EBUILD warlock-1.3.3-r1.ebuild 904 BLAKE2B 68cfb0dec958bc903025eff0c018364d8d3583bb59484362736e9d7d62298ca3da992cd05f27ce8f80bf63050911c2987ebeed8b8cce3301ec534790f5f66a40 SHA512 ef54efdf539e26a4705af902a7b4705e13c75211d9b47f0f782b272f572509ffe5f66b448d8a3eb05a02e0fada7785763e5ea4edf7b3ed9b8a7192cb5fc0d415
+EBUILD warlock-1.3.3-r2.ebuild 1024 BLAKE2B 50ca7254fbc723176f06c4c6e6b2bb388877c9c5e98a4396dcb474163d2d3af907260e575929e944497c3bb8a4928841c1a4bf159fc7f4b5850e2a17f152b840 SHA512 75c25d50b5c67bc510cd539034e5e5aafa4ee5430687d9f1aaf37e94f3a75a6660858b4c124936ca1a83f5f3d4c9a67e19d2a13712be550ca5f879081fbc9ae5
MISC metadata.xml 482 BLAKE2B 28941971c8e9ae4f5d1685ac1b9e53497235a62180a4c18093b54c576211b39f3048433d317ffb587a1335042b3894b8bee32cd903a97eee249c4864cfdec357 SHA512 99840c6ff45fdd5a4cb6a06a9322cfcd167b89a540d092fd75851ceb5a03ebce26c7c4adf702b41cc209eb1efd924aab50809c2840799fbb711578185cfbd61b
diff --git a/dev-python/warlock/warlock-1.3.3.ebuild b/dev-python/warlock/warlock-1.3.3-r1.ebuild
index c49438cbee87..0086c8697dbe 100644
--- a/dev-python/warlock/warlock-1.3.3.ebuild
+++ b/dev-python/warlock/warlock-1.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,6 +19,12 @@ RDEPEND="
>=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
<dev-python/jsonpatch-2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
- <dev-python/jsonschema-4[${PYTHON_USEDEP}]"
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # broken by jsonschema-4 but this package is dead and glanceclient
+ # (its only dep) does not seem to be affected
+ tests/test_core.py::TestCore::test_recursive_models
+)
diff --git a/dev-python/warlock/warlock-1.3.3-r2.ebuild b/dev-python/warlock/warlock-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..00daf64b32b9
--- /dev/null
+++ b/dev-python/warlock/warlock-1.3.3-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python object model built on JSON schema and JSON patch"
+HOMEPAGE="https://github.com/bcwaldon/warlock"
+SRC_URI="https://github.com/bcwaldon/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
+ <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # broken by jsonschema-4 but this package is dead and glanceclient
+ # (its only dep) does not seem to be affected
+ tests/test_core.py::TestCore::test_recursive_models
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pytest.ini || die
+ distutils-r1_src_prepare
+}