summaryrefslogtreecommitdiff
path: root/dev-python/warlock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/warlock
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/warlock')
-rw-r--r--dev-python/warlock/Manifest2
-rw-r--r--dev-python/warlock/warlock-1.3.3.ebuild25
2 files changed, 9 insertions, 18 deletions
diff --git a/dev-python/warlock/Manifest b/dev-python/warlock/Manifest
index 4f753a83f738..59a875631e44 100644
--- a/dev-python/warlock/Manifest
+++ b/dev-python/warlock/Manifest
@@ -1,3 +1,3 @@
DIST warlock-1.3.3.gh.tar.gz 11147 BLAKE2B 1281348076500315c5aa105691b8e5a50ccf2ba79335fb8581a0b89bfc96bb3076a797c4ebe011f6c347667a0971bbbdd2b1bf413d0692ae5977216c524cbee0 SHA512 8a9135a17ccc0d0939ad98eee16100ec68b911d672b3af549f7629edcd6e08129f9e4ab707082593274fc896bc405ab6d6ba9e4bf6fc40b8522ec99327c983ec
-EBUILD warlock-1.3.3.ebuild 1068 BLAKE2B 8d1f864714b89be608ccb9b8694568af13ac22e574825b166b85ec914a919af84af2bc968533ae37909f7ce00566dfbc1b8d82353c37337af4e0257a7a005ad8 SHA512 26ff343c16a12071f9dee24d4c9b0ee21c6a06067d9d6733fcfcb3b5d8d735c413231632a64d9a44e3b02340773fb7b617c962962fa155775e3091b61cfe8e4e
+EBUILD warlock-1.3.3.ebuild 716 BLAKE2B c8d53b6778627487ef8342a0e5b8c2cc3c0d1b4ee323fe41ca9674b72cff3e49e8c53940e4f7a95c7361f7c6c9dc52cf5a0ca04b369bfc7f71d6a2646b8a8d8a SHA512 4a02713d53f48824cd6d8d2556962808706e0ce06d30cc4dbb6f1eff458afdb6b9bb751b0473a93f40249a6c01eb116c91a9f2ce56524272c8b2b8de149bf25f
MISC metadata.xml 481 BLAKE2B aff1012a1482024186193a16b8e8abab85b300f76ef10a235ed9a40cc25586d4fbf632f37e2bb5a050478c74128cf0b2243345429f6edaa9a5a4b53276637f1d SHA512 1ec1e5a94f222a031e0f73c06c60a76d1e16cdb637d4ade4f0fd1deef8d51fb35cec46de7087c245fe68b8cc77637be822fb7eb9aa6b9379331a797d4e3a0166
diff --git a/dev-python/warlock/warlock-1.3.3.ebuild b/dev-python/warlock/warlock-1.3.3.ebuild
index c016724851b8..9aeb1ca4cddd 100644
--- a/dev-python/warlock/warlock-1.3.3.ebuild
+++ b/dev-python/warlock/warlock-1.3.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -13,21 +13,12 @@ SRC_URI="https://github.com/bcwaldon/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.g
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
- <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
- <dev-python/jsonschema-4[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
- <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
- <dev-python/jsonschema-4[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
+ <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-4[${PYTHON_USEDEP}]"
-python_test() {
- "${PYTHON}" tests/test_core.py || die
-}
+distutils_enable_tests unittest