summaryrefslogtreecommitdiff
path: root/dev-python/wand
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 08:31:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 08:31:06 +0100
commitb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (patch)
tree6ff0b08fefeec2ae1d739e566814553b80b9d685 /dev-python/wand
parenta6266c63b23ed0ee16865627ca53e4f5353f0a5c (diff)
gentoo auto-resync : 17:07:2022 - 08:31:06
Diffstat (limited to 'dev-python/wand')
-rw-r--r--dev-python/wand/Manifest2
-rw-r--r--dev-python/wand/wand-0.6.8.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index 127fddd096f3..e42aa34b26a9 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1,4 +1,6 @@
DIST Wand-0.6.7.tar.gz 11686093 BLAKE2B 58abbdc22eb1603ed42e2e2473c0ed2b9026c9c0a499bb885512b56ecf01fb4ffe450979808bba2b4c4466994f86bea9a9c0ced216f8338c845b96a755f39c9f SHA512 e79ecb909f6ad7b3ddae217bb7b27f3c010d22a40eb99866e2a6eb07346000acbead280176e3352da13c20b68a341c751c55d6203bef7968522c8dbcfcab0b06
+DIST Wand-0.6.8.tar.gz 11884527 BLAKE2B 45784abf55682d8b5e101cc4fc93f0492f9275a2805f06dbda2d98e28c6359c7df84fd7870b12348c0a6c513ae3f2bafba61a00020a41263d6a91fd67d9ce682 SHA512 111eef211edd8d5a6c825f0b455db5510c91b43852165934dbab36a9cdeea7e920987c98d975fb8c7f82ac19f20867c0ed5c8c1e2f9dd9467bc30931b4a03dd1
EBUILD wand-0.6.7-r1.ebuild 725 BLAKE2B 744d613a797f5234560def501a49e49f97800148600c46a1a17338070e6370b279ae8cb30bb86a8c9129647be4c353fd7ec3576a7b5f29e589258bd80afc2e29 SHA512 c60ad6aabd3e2ba297f8394d5741b00360c689d35b02934bb319b633819267aae126e863db7c85beb0643dda380e323e3ae0c2de77bed2485b015777da41fb0c
EBUILD wand-0.6.7.ebuild 693 BLAKE2B 2fb65a5aafa6af1e39919bde33b704d3dd06f3974b472b8bd2eddb13a8d267a4541afc46d857adc6cc6100f81247e12defa0119320216e2a8bc2d5dd78e5e7e6 SHA512 ce87a3e330c250fcf8a5e02f02db6532e93958288fd26904921ae8ca370690871ec6c1a6f0c2d72e7400a4b5b12dd1cfe0a6d393033f55dbb93e9af187bed7f0
+EBUILD wand-0.6.8.ebuild 799 BLAKE2B 26c6b310db4aeb8b9b1aae8f96b80c5067ab7159398a7ca6f7870deb5f7128dc080f7ed4fa77422a7a263deeaa022fbad6cda9e8a862b2b8c8e70141d78b5452 SHA512 96355dfe9edb46610e62fc30a3190362d002b52edb58ec045ed9e4d9b00fc4ec88513a9a151446309d4d1ea8f9443047a5ab4b88f2a27fa6cc6c3a8d49788271
MISC metadata.xml 534 BLAKE2B 0c2295ce9b9805ceff22c9549adfa46578a5d5d1d4f13b7af416ad23f305ee24275deb7204a68076901e6060d41a3935580e24578d2fe56a2c32817ab83165b5 SHA512 68f30bc7ad8cf6a451acf550c02b76e1f71a8c66c9ffc8832995bd292bd460d16c9526e5bb2daaed9cabece9591499f9dd3b0f11d748af247c78654d6104ee13
diff --git a/dev-python/wand/wand-0.6.8.ebuild b/dev-python/wand/wand-0.6.8.ebuild
new file mode 100644
index 000000000000..753e731d2674
--- /dev/null
+++ b/dev-python/wand/wand-0.6.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="
+ https://docs.wand-py.org/
+ https://github.com/emcconville/wand/
+ https://pypi.org/project/Wand/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-gfx/imagemagick
+"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}