summaryrefslogtreecommitdiff
path: root/dev-python/waitress
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/waitress
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/waitress')
-rw-r--r--dev-python/waitress/Manifest5
-rw-r--r--dev-python/waitress/metadata.xml12
-rw-r--r--dev-python/waitress/waitress-1.0.1.ebuild33
-rw-r--r--dev-python/waitress/waitress-1.0.2.ebuild32
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/waitress/Manifest b/dev-python/waitress/Manifest
new file mode 100644
index 000000000000..44e2998ac2f8
--- /dev/null
+++ b/dev-python/waitress/Manifest
@@ -0,0 +1,5 @@
+DIST waitress-1.0.1.tar.gz 123934 BLAKE2B 1e7d2a2d0850096b6b0d5654208ebe23d4e78360d8eedf3bce98276b8710eac0f544158f9efe5fa72abbab27d3ca5c4f3ed9afed43144d4d06f88f8068b2f19a SHA512 0205a0a5fc9e65e20370fc1e97ba456337313c93817e9b2b283610e5045eb32de80f45d19ee0cfb9469a93e4fc9267b785feacedd70b362474f4af5c05a3ab21
+DIST waitress-1.0.2.tar.gz 124685 BLAKE2B 4c9edd2d7c37964616311ee6fe5a58ff1f6a7677226956e47f03f629d7765b3015c1f652f39ad7b0f81608f8638e63edeb35f120ee57347e89b029918e418c04 SHA512 b7000e1198ac306ce189f70c5dcfcf41318e5ec47c8d6183cdbc360c8759ca726405d5da70f1c7fe3cfeb39d528af94d693767c2a7a1a7fe460c6407857ec6f0
+EBUILD waitress-1.0.1.ebuild 796 BLAKE2B 82ef2f706193f159e8443e942fe40da112a9d56d5b2dafc752ad56df93a1b1bbc35d62a6fe5f06a388add59da0fd334382c4695eeef6884122804c8039535dbe SHA512 8affcf2d4d81bd7188da21173a1ecfc8eb7817b9f2db5f1c3518f404aea6081f7eeb5585c2ce630c2963aceb9495ba86f48fb5bab333bee308287b634b744e5c
+EBUILD waitress-1.0.2.ebuild 784 BLAKE2B 117586dd8b186084afa7463fc01c63b7a01e8bc4eaec492a01f14c487acf2ab095468a0f08382cb2911f86a4a7e144cba68ae68c05352af2875e3d5df4ebf399 SHA512 7712de5ff5cb961b9f681c0fa4a69df18ef284a3522d98043bf76ccb85e76b00db54fcfb548047272cd59d982e214232d6eb3ba0ef7b0c5177a8f18ef378841d
+MISC metadata.xml 378 BLAKE2B ce0ade449ef1c9d58ced1c883c0adb2a27573bd74f5299bdda36ee60fe073a56e8c44f5a81a36bdd7fa2c595c1a2f55abd3eb876fd5d0909256bff4310fdaabc SHA512 02bd27d7e984ce3ca047d34dd5acfe9c0b23e9d8fcf59484262e19e9df1206939fe2837a58ac00fe58575c2db4abe28b89a5a1c8a8b887d346c30635ee2b10fe
diff --git a/dev-python/waitress/metadata.xml b/dev-python/waitress/metadata.xml
new file mode 100644
index 000000000000..7c0760738bbc
--- /dev/null
+++ b/dev-python/waitress/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">waitress</remote-id>
+ <remote-id type="github">Pylons/waitress</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/waitress/waitress-1.0.1.ebuild b/dev-python/waitress/waitress-1.0.1.ebuild
new file mode 100644
index 000000000000..3a99c57754a6
--- /dev/null
+++ b/dev-python/waitress/waitress-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="https://docs.pylonsproject.org/projects/waitress/en/latest/
+ https://pypi.org/project/waitress/
+ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/waitress/waitress-1.0.2.ebuild b/dev-python/waitress/waitress-1.0.2.ebuild
new file mode 100644
index 000000000000..73232710f7f3
--- /dev/null
+++ b/dev-python/waitress/waitress-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="https://docs.pylonsproject.org/projects/waitress/en/latest/
+ https://pypi.org/project/waitress/
+ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}