summaryrefslogtreecommitdiff
path: root/dev-python/w3lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/w3lib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/w3lib')
-rw-r--r--dev-python/w3lib/Manifest3
-rw-r--r--dev-python/w3lib/metadata.xml15
-rw-r--r--dev-python/w3lib/w3lib-1.18.0.ebuild20
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/w3lib/Manifest b/dev-python/w3lib/Manifest
new file mode 100644
index 000000000000..877347c6e97f
--- /dev/null
+++ b/dev-python/w3lib/Manifest
@@ -0,0 +1,3 @@
+DIST w3lib-1.18.0.tar.gz 37709 BLAKE2B b6fc2b7198cbf82ab509c7b2d9d77c4362840ffb70122476684d16c7c1f0ca3b9b6fdc63985a0c3eea5498c16595a4fd18a5179865d66fdd657a0c9c526194e5 SHA512 5d7a3453081eae79807f6287f862b1b6af196d1f3db19c4063d1730b0e736496e3bf2c96021d4b7237cd448a52450131e2a136c776d0ca74b4222965033289e7
+EBUILD w3lib-1.18.0.ebuild 490 BLAKE2B 43868c18642669cb6305752f4a3448a348c4168d79a79252ebb7f025075a58e70e8ba92891d2727b9d7f47fe1eab42822926a1b861f366e3609d94c6972c94af SHA512 18e3a49757822dc3f646cad3fa47eb91cdc85906d87f73feba336757e4b6ec5a2a324a5ed2dc6130be064c9183ae10a0b0b9037b6c748637ff30e21ce8369b8c
+MISC metadata.xml 457 BLAKE2B 3330b2292c818d9bc66cbfd91ec93655d0285003778c39e8acbe267f16f46dd175639f5c88f9cc388d7d856ce1c463da62131a548e0bed0075f0a5e79787fb7d SHA512 5136e07ca268ec52f678a36a8aa2fc254d74e104da0303b5427386bcddd86618f6a76383a4808cd7aff3e179294825f8b70458bc7341e062164ae78e5f5b2569
diff --git a/dev-python/w3lib/metadata.xml b/dev-python/w3lib/metadata.xml
new file mode 100644
index 000000000000..75452b6af9f7
--- /dev/null
+++ b/dev-python/w3lib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">w3lib</remote-id>
+ <remote-id type="github">scrapy/w3lib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/w3lib/w3lib-1.18.0.ebuild b/dev-python/w3lib/w3lib-1.18.0.ebuild
new file mode 100644
index 000000000000..6c572622b29f
--- /dev/null
+++ b/dev-python/w3lib/w3lib-1.18.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library of web-related functions"
+HOMEPAGE="https://github.com/scrapy/w3lib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/six-1.4.1[${PYTHON_USEDEP}]"