summaryrefslogtreecommitdiff
path: root/dev-python/vpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-python/vpython
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-python/vpython')
-rw-r--r--dev-python/vpython/Manifest2
-rw-r--r--dev-python/vpython/vpython-7.4.6.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/vpython/Manifest b/dev-python/vpython/Manifest
index 088ff1d431e0..1b3ecfcd0aed 100644
--- a/dev-python/vpython/Manifest
+++ b/dev-python/vpython/Manifest
@@ -1,3 +1,5 @@
DIST vpython-7.4.2.tar.gz 3960161 BLAKE2B e5a0d441f350af1b3390bea943fe5a5a9083234c415b93bf10bbc8109eb280050b447c95e93c18549f5c74a8c3ae43dfe6817cdc4055e4a8a7ad7f66b54c5342 SHA512 dd4db13743f733ac0bfcaac5520da193df9c0f7fc6198f1d55723e45a6e39f642f09f66a3f217669e70027a30c2f8426c0a80bee0d4cbc33b77ac5c927c7e3d0
+DIST vpython-7.4.6.tar.gz 3542460 BLAKE2B 358bd33f386b27ade92088af07fd5a73c1fccd5dbe729fe989f802b1db0eff38014bc38baf383324bb6299f53c68df8cfe9070a6d805303e0b50d4088af133ee SHA512 68591fc3bf71ae1b87e86a61574c46bb64a041ab29309ced64ef69c6d110e0fcd4f3d3adaab2ae76b21df9f66314095c4b3d79e6ebf1d60fa7725f85ae7a7b06
EBUILD vpython-7.4.2.ebuild 637 BLAKE2B e8e5ad015c58e8e19a837175128590770034ce5dd7b3d6343f3564c84e6d5d639dfd0a1464f9b1594a8f58802c1e0ae4115b863254010a02208ee53496b106a3 SHA512 5609cebe41dc502215d03222b234fc5f66ed105a78887d32ad196e2a324672e71d2a20b962e62b25c69acbf6fc53897782dd55634f440ceef8e110596f47b950
+EBUILD vpython-7.4.6.ebuild 637 BLAKE2B e8e5ad015c58e8e19a837175128590770034ce5dd7b3d6343f3564c84e6d5d639dfd0a1464f9b1594a8f58802c1e0ae4115b863254010a02208ee53496b106a3 SHA512 5609cebe41dc502215d03222b234fc5f66ed105a78887d32ad196e2a324672e71d2a20b962e62b25c69acbf6fc53897782dd55634f440ceef8e110596f47b950
MISC metadata.xml 621 BLAKE2B 9b76c9b14bafc55ba1e99bf584a43ebc4414183230809eae1994db3cf10b35e8d7591db002828c9a18e25c73c55183a0a27812d4b6491d282c2229bf17761733 SHA512 fa384102ed51e900a7b27be256688c2fe94cb9e08f5240f116ad3ee4b2581e47b2956efb6446de448554718311e212dde2eecedb5c9ecd01a59dff7e2f14eacc
diff --git a/dev-python/vpython/vpython-7.4.6.ebuild b/dev-python/vpython/vpython-7.4.6.ebuild
new file mode 100644
index 000000000000..242bea8fdc7c
--- /dev/null
+++ b/dev-python/vpython/vpython-7.4.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="http://www.vpython.org/ https://pypi.org/project/vpython/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"