summaryrefslogtreecommitdiff
path: root/dev-python/visitor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/visitor
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/visitor')
-rw-r--r--dev-python/visitor/Manifest4
-rw-r--r--dev-python/visitor/metadata.xml17
-rw-r--r--dev-python/visitor/visitor-0.1.3.ebuild31
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/visitor/Manifest b/dev-python/visitor/Manifest
new file mode 100644
index 000000000000..b8429412431e
--- /dev/null
+++ b/dev-python/visitor/Manifest
@@ -0,0 +1,4 @@
+DIST visitor-0.1.3.tar.gz 2985 SHA256 eaefe1cfc3b40b2a54579b028230a1ea1cf1cb884b7a347b7350a18cf37e8019 SHA512 414c77df8efcc22df5ee8073e02b8c5c28563954ef9b9a869c4ea3f7f1268a97929c1fe29142ba41e3a5acafea52599f6bf073aacd654643d7d8380cd4f41fbc WHIRLPOOL 6e436e9d8e8d68ca3d891022eb8c9c2182ec3c37d24cf543aefb78330f7d5fd1c4363f4a6b9a16c5a6bd8c63d676a27aabf770d27a266f4c8f4f7e4b22bf91ed
+EBUILD visitor-0.1.3.ebuild 710 SHA256 e21ed63a85615630f8d8e135ceaa5dc905829aad203acd3fafa0bedc1ea6a7c4 SHA512 59efc119c4d4908349134c74c0b00338f2ee56b62fa82c320f5108880839ade114ec71635bcfd19b628ceb8359a56745e6d3cc0d82aa215fd2a7b4ee2a1fb9a9 WHIRLPOOL 4042c2256efa58c519824d23e75d8fb1c204f6184eb18cf9bbfff85b016f6996f0a5f7243c91e3ea50825d38be3376eeff54896d0fd80ae9e997e42a6edc05af
+MISC ChangeLog 963 SHA256 dae326cbfeb6b55f7881d1bba247978ef49c9f3b942f0d5a1a16c0e9304c6e18 SHA512 218124a35f6f2cd1d799143ab909e3ecb86b2ee4255728142cb7a9913437a84803f37e4d68f7171deb47dead4742d1d32e6deb9da9a38ca37e9c58c35cadde9d WHIRLPOOL 0c024eea2d4e09f358d83cc1d52f4e9980bbe20dedccca92397a8e72e4a1e16375b855317dc51ad9960858fb51dc492ddbd17a918292e66b7bf58fddeacbd6cd
+MISC metadata.xml 549 SHA256 e26723a95120a4ca7201adfa574cd5bbc53cfff38d7fce40ba870e75477da2d6 SHA512 c492e7e62104525a743d8e07de51b82fd44d07a29d57ed20467da0f79a429245e1676ccbda789f0510e3f3215e90fc000b9dd882239b2eb3bebde9f03e71bade WHIRLPOOL f541221202b5145c20fe84c209f1e49b1bc0f228376da8a97b78993378c833622385a44531ff5742021b3fa68516268b69331a138d80aca82e9829b7f3009cdd
diff --git a/dev-python/visitor/metadata.xml b/dev-python/visitor/metadata.xml
new file mode 100644
index 000000000000..38969880dd20
--- /dev/null
+++ b/dev-python/visitor/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">visitor</remote-id>
+ <remote-id type="github">mbr/visitor</remote-id>
+ <bugs-to>https://github.com/mbr/visitor/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/visitor/visitor-0.1.3.ebuild b/dev-python/visitor/visitor-0.1.3.ebuild
new file mode 100644
index 000000000000..a29aadde8829
--- /dev/null
+++ b/dev-python/visitor/visitor-0.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tiny pythonic visitor implementation"
+HOMEPAGE="https://github.com/mbr/visitor"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/visitor/pull/2
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}