summaryrefslogtreecommitdiff
path: root/dev-python/vertex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/vertex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/vertex')
-rw-r--r--dev-python/vertex/Manifest5
-rw-r--r--dev-python/vertex/metadata.xml19
-rw-r--r--dev-python/vertex/vertex-0.3.0-r1.ebuild26
-rw-r--r--dev-python/vertex/vertex-0.3.1-r1.ebuild32
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/vertex/Manifest b/dev-python/vertex/Manifest
new file mode 100644
index 000000000000..a91cd896e34b
--- /dev/null
+++ b/dev-python/vertex/Manifest
@@ -0,0 +1,5 @@
+DIST Vertex-0.3.0.tar.gz 84997 BLAKE2B 8f6a2955c4674888f7608590390f4cfbf5063e08281fc2a49a4cf9543a7b769df6e355bd87044f6eb23009ab50e7efbbbf5d0a471627780e9869008c764f0e8b SHA512 206d142cc72b2d77ed8c8fe222770eabc1a8c179238f46554abc5d833669f27bd286565e20ccaf5594d456b23b54455b23ab0eca5b8b4f72a7961924e7167676
+DIST Vertex-0.3.1.tar.gz 89909 BLAKE2B d26b73c5079f0401185e534aa9c35f7fd490eae9b27cd36915e3f2508b1ff6feda3a900bc3230d7f24f563546d6a966441b8618d066f28f647878597df4b9df7 SHA512 7e9b96a7ba493254ff58e8f75da6517c09c4502c21702a96c29525a78569ff7d988cd7278dd87983485b6da30a607820a7edb28375e37d5e059d6f0638a1b1c9
+EBUILD vertex-0.3.0-r1.ebuild 667 BLAKE2B a9094bc4de473ad53c71ad9683dd33c1c2c89663136dd4d89881c83f99d48af5c0e203f47b9d94e0f67b4720a5810ac25a7d1905a5b3a02628b804f0786aaed0 SHA512 5e3d2fe7386f1bcc038432966fa011fd856eae71d1e099099cb8de238ccaf667e7feef3a59ce46275f9a40da03bb9f1bf6110baf5adc1aee766d7468d3509439
+EBUILD vertex-0.3.1-r1.ebuild 832 BLAKE2B 906120c24aa43b8282a30502c34db88865296dba064ae1bcf72e0f32fa140fae77a71c3d979424ab9f68f36c74fa524cbe3c23b9c675eadc7ec8c230bf9d4d96 SHA512 8d0505dad7db50fa9abb09e5dfc519d66e759628c857fc2227565db2ca51d75581b57f4bff87b7b7337811cc3e8a63d1e0a26bab2800c47a7021d51b27ad96dc
+MISC metadata.xml 896 BLAKE2B f97fc09b3dcb3c78d457127762d33c2822c91ef1e8ac5e7bc254452ac443e8cd8bc01d3e90dc90de4060c426f2f8238ea9423dec9532d2d52200ec0953938252 SHA512 71c0e6e5ab8584a10daf920a7cf7d2b1a05ca6c6ec8c8b82bf589897fe85ebd652ad41e4b2b44f0ce345111b83c44f263ffc7eec93225cd96b0479b7548255e3
diff --git a/dev-python/vertex/metadata.xml b/dev-python/vertex/metadata.xml
new file mode 100644
index 000000000000..903c836f7a27
--- /dev/null
+++ b/dev-python/vertex/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">Vertex is an implementation of the Q2Q protocol (sort of like P2P,
+ but one better). There are a few moving parts in Vertex: PTCP is a
+ protocol which is nearly identical to TCP, but which runs over
+ UDP. This lets Q2Q penetrate most NAT configurations. JUICE
+ ([JU]ice [I]s [C]oncurrent [E]vents) is a very simple but immensely
+ flexible protocol which forms the basis of the high-level aspects of
+ Q2Q. vertex is a command line tool which exposes a few features
+ useful in many situations (such as registration and authentication).</longdescription>
+ <upstream>
+ <remote-id type="pypi">Vertex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/vertex/vertex-0.3.0-r1.ebuild b/dev-python/vertex/vertex-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..1cee997855be
--- /dev/null
+++ b/dev-python/vertex/vertex-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="https://github.com/twisted/vertex https://pypi.org/project/Vertex/"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc NAME.txt
+}
diff --git a/dev-python/vertex/vertex-0.3.1-r1.ebuild b/dev-python/vertex/vertex-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..96cb433a368a
--- /dev/null
+++ b/dev-python/vertex/vertex-0.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="https://github.com/twisted/vertex https://pypi.org/project/Vertex/"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ >=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pretend[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc NAME.txt
+}