summaryrefslogtreecommitdiff
path: root/dev-python/versioningit/versioningit-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 18:28:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 18:28:08 +0000
commit1f254b1ee917690b4f8f7738fdcfc295ee304ff7 (patch)
tree136ad1b72b899873af1ab7e8fcc6ec343484f41f /dev-python/versioningit/versioningit-2.1.0.ebuild
parentbcf596975a1c2450e077c80c84017c54198f216c (diff)
gentoo auto-resync : 17:03:2023 - 18:28:08
Diffstat (limited to 'dev-python/versioningit/versioningit-2.1.0.ebuild')
-rw-r--r--dev-python/versioningit/versioningit-2.1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/versioningit/versioningit-2.1.0.ebuild b/dev-python/versioningit/versioningit-2.1.0.ebuild
deleted file mode 100644
index a0d4acc1502b..000000000000
--- a/dev-python/versioningit/versioningit-2.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A setuptools plugin for versioning based on git tags"
-HOMEPAGE="
- https://github.com/jwodder/versioningit/
- https://pypi.org/project/versioningit/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' 3.8 3.9)
- $(python_gen_cond_dep '
- <dev-python/tomli-3[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- test? (
- dev-python/pydantic[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # Tries to do wheel/pip installs
- test/test_end2end.py
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e '/-cov/d' tox.ini || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -p no:pytest-describe
-}