summaryrefslogtreecommitdiff
path: root/dev-python/vdirsyncer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/vdirsyncer
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/Manifest5
-rw-r--r--dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch35
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild (renamed from dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild)24
3 files changed, 50 insertions, 14 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index 6280ba3f1691..ca1503acce15 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1,3 +1,4 @@
-DIST vdirsyncer-0.16.7.tar.gz 112786 BLAKE2B 19b9ce6e3e9de0a626b9562b4d54b270c1532d93169fe2d872f15c6bf6e1ac94bc623c171e51e871082422116636b4945b58dd172cfca527a010906737f1b6a3 SHA512 218c6781139a9e979077308dc732756cc27ecb67966e4b52be31cb1ebf04d224443036102d5c4bad253b9dcf533939f0b72082166f0fe94e042a7e946b8fad0e
-EBUILD vdirsyncer-0.16.7.ebuild 1504 BLAKE2B 8d470895fa0128ff82932bbce9c3761d6064bb399ac6deb84ce7b23e8efb1f3e281d08dd293797d7a88a772852a56f4cb8883ab86db0fc0c04e07e9ca4f27e58 SHA512 0d0ee5dfb988d2adcff9feb6d14a3c3743d36bd101527e3500f4b5fcfcf4f959c9bfd3df6eb8a54e97ac4e89f06facff9124133767cc69e8c3062e1414ab04b6
+AUX vdirsyncer-0.16.8-click-7-compat.patch 1192 BLAKE2B 33dd29de4c8497977a11052e4dc98290a981f470bdcd936f7dfc57e61a408332317805edbb0ecf50fdeb6256b91ece21f3b9582748cc5dc63cc687a68e9ecae1 SHA512 3de4131b447f789da4ae0da99f7f9f2d62dfb37b01b68db5b1c2ea68477425038681b4428024c3d743e18e2f0c3a069552066ff8743b85d2ce9bb31a4e850e9f
+DIST vdirsyncer-0.16.8.tar.gz 115819 BLAKE2B e0140718a1b41875421a7094e02cdeb865c500935e0c97bc18a614551586d79682641726df1a96e17a158604ed309f713f4caf4a484025eca5fbc6acbbe18f97 SHA512 12cb50f592085af37bd9c4207c0d31fdd38fc2a44712eb6288b12e7e7ee9af82070d1d405fa9579e935e545e6c92aafb6f8334ebde4976c4eb9412e78e7c5ada
+EBUILD vdirsyncer-0.16.8.ebuild 1466 BLAKE2B 2b2f4962c20c711b924bea9112342138a11cb0d1cca89658b16b9ab58d8319f8be7bad4f07b767768c9a78c7ac93c3de37d37dd3db00616ccb62c63115a11988 SHA512 36ae629d991d7e4d670dc04f951b57eb3157fb5ea30b04f41f429f6b044fccc441eb66c724ec3bb1f6707c5a3da773d57013f077c08dff2d8eaef0d33c5a6571
MISC metadata.xml 349 BLAKE2B 20ad2ded190f80b37283e6ef064168094e9edeec5ca6ba262e9e6d977bd28d1538056b21efa7fecc090b63424a23f87c54ec1e2e2dcd02a2f4c5ab7b4b82abe1 SHA512 5e2d7f27428065740bdee11e59053519c83054c19156f77ec03fc6e416ca44ea0b74178844ac8ef84d1993927bcf3ba0b80d84296a152a006681ed77e87ed14f
diff --git a/dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch b/dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch
new file mode 100644
index 000000000000..c0ee62f959f9
--- /dev/null
+++ b/dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch
@@ -0,0 +1,35 @@
+commit 3eb9ce5ae4320d52e6c876874511ff96a8a45f51
+Author: Hugo Osvaldo Barrera <hugo@barrera.io>
+Date: Tue Jun 9 14:45:02 2020 +0200
+
+ Add compatibility with latest click
+
+diff --git a/setup.py b/setup.py
+index 59549f16842a..d584b95dd297 100644
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ from setuptools import setup
+
+ requirements = [
+ # https://github.com/mitsuhiko/click/issues/200
+- 'click>=5.0,<6.0',
++ 'click>=5.0',
+ 'click-log>=0.3.0, <0.4.0',
+
+ # https://github.com/pimutils/vdirsyncer/issues/478
+diff --git a/tests/system/cli/test_sync.py b/tests/system/cli/test_sync.py
+index f242376417f3..43d35dd8541e 100644
+--- a/tests/system/cli/test_sync.py
++++ b/tests/system/cli/test_sync.py
+@@ -123,7 +123,10 @@ def test_verbosity(tmpdir, runner):
+ runner.write_with_general('')
+ result = runner.invoke(['--verbosity=HAHA', 'sync'])
+ assert result.exception
+- assert 'invalid value for "--verbosity"' in result.output.lower()
++ assert (
++ 'invalid value for "--verbosity"' in result.output.lower()
++ or "invalid value for '--verbosity'" in result.output.lower()
++ )
+
+
+ def test_collections_cache_invalidation(tmpdir, runner):
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
index 2a312ce64647..eba73bc32ea9 100644
--- a/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
+++ b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,32 +13,31 @@ DESCRIPTION="Synchronize calendars and contacts"
HOMEPAGE="https://github.com/pimutils/vdirsyncer"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
+LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${P}-click-7-compat.patch" )
RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
>=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
<dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
>=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
- !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
>=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="${RDEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
- >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5.0.0[${PYTHON_USEDEP}]
dev-python/pytest-localserver[${PYTHON_USEDEP}]
dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
)"
DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+distutils_enable_tests pytest
+
python_test() {
# skip tests needing servers running
local -x DAV_SERVER=skip
@@ -45,5 +45,5 @@ python_test() {
# pytest dies hard if the envvars do not have any value...
local -x CI=false
local -x DETERMINISTIC_TESTS=false
- py.test -v || die "Tests fail with ${EPYTHON}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}