summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-16 23:37:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-16 23:37:06 +0000
commitd228f661892a9e55a86f00c2c14625490631d797 (patch)
tree1ff5297945a5544ca5b30a9206eb788ab4c431d7 /dev-python/vcrpy
parent3b00f2d2f95f5d6ff01e71259eb94fa714a92232 (diff)
gentoo auto-resync : 16:02:2024 - 23:37:06
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest3
-rw-r--r--dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch40
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.1.ebuild5
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index c8a6bb76aa45..b80fb2cb101d 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,4 @@
+AUX vcrpy-6.0.1-httpbin-compat.patch 1921 BLAKE2B 7ac8e0fa08f38b2b1f3bf78f80485a32d2ca2a56bff4c9c70b42049a6ed37dadd25f25fedd77b578d7452b87bf74825b0bd062186f74c9cc6a7017be6fe189f7 SHA512 81b87869bf8af2b853ff5a336c45ac1b26ed8f49729e2da94859b621d1110a07081d280dfb541fab0a8bb2ad48c26be48a3966f17a7455242da0b150a569c0c8
DIST vcrpy-6.0.1.gh.tar.gz 337497 BLAKE2B a00571d7ed0dd895cc120e3e2615e8e6ea3e86344813e87f836a182be45389b200925ae2a02dc754b0b77db642d3be453b3b8c909b26197222b84fa95c6da804 SHA512 79ba9ea29db20ddc3db5676d7bdb05da17848eb126ed63d813a1d2b0de80573fff3afaec2ffe1af491a0310ce922c7545c4569035d0f5868f171db25965c217f
-EBUILD vcrpy-6.0.1.ebuild 1647 BLAKE2B d087ff5d409691f23d13059e9530cf317aeb7376d820aba82d0669c68c0386e933128e6c07b302109dda6bb3dc65053d296721d50d2e4827a54cf4d40b5db471 SHA512 867354a621ba19e5f1605591bc40d98d0509f95e534edee4c5c99dc5ca06fa8b05f7ba15efd4366c8e5d7f9e005d24bc4a234c01ef35fbb508817660ae83382a
+EBUILD vcrpy-6.0.1.ebuild 1748 BLAKE2B ef578ea72d3b54a75e3d986932d1d170b6abbc14d42df5304e796c92853f95cfd1a0ae722adff5a063babc0dd53aa63e26e24d9c69bc19a4353fc8e62d653b86 SHA512 af5de06049c920f8ebfd13a11378667dddb87d6ab12e42bca8893443d42f680261c95d4c798d4f42ca9bf458e4350eae96439aead717b5d51382b39519078ee0
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch b/dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch
new file mode 100644
index 000000000000..4e2a91cb4bac
--- /dev/null
+++ b/dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch
@@ -0,0 +1,40 @@
+From e60dafb8dce589e7deb63fec552f5c05bd19ac6d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 16 Feb 2024 19:33:41 +0100
+Subject: [PATCH] Improve test compatibility with legacy httpbin index
+
+Make the tests slightly more flexible to match both the flasgger-based
+and legacy httpbin index. This is needed for compatibility with
+https://github.com/psf/httpbin/pull/44 when flasgger is not installed
+(e.g. on architectures that are not supported by Rust).
+---
+ tests/integration/test_basic.py | 2 +-
+ tests/integration/test_register_persister.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/integration/test_basic.py b/tests/integration/test_basic.py
+index bfad6153..99121456 100644
+--- a/tests/integration/test_basic.py
++++ b/tests/integration/test_basic.py
+@@ -39,7 +39,7 @@ def test_basic_json_use(tmpdir, httpbin):
+ test_fixture = str(tmpdir.join("synopsis.json"))
+ with vcr.use_cassette(test_fixture, serializer="json"):
+ response = urlopen(httpbin.url).read()
+- assert b"A simple HTTP Request &amp; Response Service." in response
++ assert b"HTTP Request &amp; Response Service" in response
+
+
+ def test_patched_content(tmpdir, httpbin):
+diff --git a/tests/integration/test_register_persister.py b/tests/integration/test_register_persister.py
+index e904197c..375f14be 100644
+--- a/tests/integration/test_register_persister.py
++++ b/tests/integration/test_register_persister.py
+@@ -66,7 +66,7 @@ def test_load_cassette_with_custom_persister(tmpdir, httpbin):
+
+ with my_vcr.use_cassette(test_fixture, serializer="json"):
+ response = urlopen(httpbin.url).read()
+- assert b"A simple HTTP Request &amp; Response Service." in response
++ assert b"HTTP Request &amp; Response Service" in response
+
+
+ def test_load_cassette_persister_exception_handling(tmpdir, httpbin):
diff --git a/dev-python/vcrpy/vcrpy-6.0.1.ebuild b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
index 6e8afec2a509..257bac69d0b4 100644
--- a/dev-python/vcrpy/vcrpy-6.0.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
@@ -38,6 +38,11 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/kevin1024/vcrpy/pull/823
+ "${FILESDIR}/${P}-httpbin-compat.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=(
# these tests are failing with recent dev-python/werkzeug; losely related: