summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 09:20:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 09:20:57 +0100
commit8d8735134b6bb6e159162e531cccb456691a4ed4 (patch)
tree7de189548ab429e5684318a71880f458c7a43dd9 /dev-python/vcrpy
parent83cfc3cac0511042177fc061cc188c99bf900be9 (diff)
gentoo auto-resync : 03:08:2022 - 09:20:57
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest4
-rw-r--r--dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild62
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.0.ebuild2
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index f3a5cdd6118c..12e422a48a33 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,5 @@
+DIST vcrpy-4.1.1.tar.gz 329508 BLAKE2B b6981150a8fd742301e0d7897d84855c741c97307bbb5c5751680f3d33d69d6333a18d714fcc14cb018f5dd6c02e840e1313136660c4459e2755d448fc0b07e9 SHA512 afa1904bff37bfd2d278ed49fa3982a357eb6bb113818b532044da0f11a9dd877cc152d7f0d81d88bdc0f870521b1241f6aecf959f668211904e3c6c7cea4ad8
DIST vcrpy-4.2.0.gh.tar.gz 331096 BLAKE2B dccb9310da42c6f75d0d503cb64aa09876447098bff2ad6a1507a0e0907ce05a89d46ccc159e79f310e027fc8f3075b7474274ad39ca4778acbc6d2a8f633004 SHA512 61eeec585fc78be1ae6d4f9047123c9680611e436bb5980fb7c6b885e16b2ef9bd5ce921efff7e87a222b3662c7009dbf0a8df24cdb9849d09deb24957ba4889
-EBUILD vcrpy-4.2.0.ebuild 1585 BLAKE2B 4329d7fa8facfd83c46263e1f0e8993204f36e5be316e9e960b5aaa82542fa72e0a176a5c8614ea5a410b58b916658c08ec779f369f2c63232dc4d484db98003 SHA512 68a34453060fde72b1dc7addf00560ec39b1593bee154a67c708b97011969f8485f9d2e104097b658d46efdee6f293d183dab16cd718ebf40686cb4eb509106d
+EBUILD vcrpy-4.1.1-r1.ebuild 1798 BLAKE2B 93f6511d7b8f36910b79d61fd68333e2c1b912d099c011e2eaa6b8bb33462b640f7b319ad3e110bf826892507e9413e0c9e364cc92f8ef70829562f47f423750 SHA512 2ac1af65fdd13d862898dde4771f7dc5ac1e3e9c1236e85c6be171c13dc54af9445a59a33cf8bdc6e5a84b290ac568630d3296b8791b1ae14185196232e33049
+EBUILD vcrpy-4.2.0.ebuild 1593 BLAKE2B 359d63051ec8151b5a0e02ae9fa1239741ee86e9aae3f8f1a86983493470f8346b1597a85999837254fde55c652eecc29f6ee38ef467d261db05240022487159 SHA512 a3951db7a796f14771f758f00f7f4e49cb408dffec886a8c9d44bcf9460e6c647646b1b202207b19ea7097b6c86993fe25d83a7f2d1401a3964d4ce4a99c3b0e
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild b/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..e1d011d9d398
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests require Internet
+ tests/integration/test_aiohttp.py
+ tests/integration/test_boto.py
+ tests/integration/test_httpx.py
+ tests/integration/test_wild.py::test_flickr_should_respond_with_200
+ tests/integration/test_wild.py::test_amazon_doctype
+ tests/unit/test_stubs.py::TestVCRConnection::testing_connect
+
+ # probably unhappy about ssl module being more strict now
+ 'tests/integration/test_httplib2.py::test_effective_url[https]'
+ 'tests/integration/test_requests.py::test_effective_url[https]'
+ 'tests/integration/test_requests.py::test_redirects[https]'
+ 'tests/integration/test_urllib2.py::test_effective_url[https]'
+ 'tests/integration/test_urllib3.py::test_redirects[https]'
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest
+}
diff --git a/dev-python/vcrpy/vcrpy-4.2.0.ebuild b/dev-python/vcrpy/vcrpy-4.2.0.ebuild
index d7b461c16f56..8f48fb71765f 100644
--- a/dev-python/vcrpy/vcrpy-4.2.0.ebuild
+++ b/dev-python/vcrpy/vcrpy-4.2.0.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
RDEPEND="
>=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]