summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/vcrpy
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-4.1.1.ebuild35
2 files changed, 20 insertions, 17 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 81a2c5ba2ec3..5acf6702abd0 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,3 @@
DIST vcrpy-4.1.1.tar.gz 329508 BLAKE2B b6981150a8fd742301e0d7897d84855c741c97307bbb5c5751680f3d33d69d6333a18d714fcc14cb018f5dd6c02e840e1313136660c4459e2755d448fc0b07e9 SHA512 afa1904bff37bfd2d278ed49fa3982a357eb6bb113818b532044da0f11a9dd877cc152d7f0d81d88bdc0f870521b1241f6aecf959f668211904e3c6c7cea4ad8
-EBUILD vcrpy-4.1.1.ebuild 1445 BLAKE2B 2886ead28eff8854f2ea2ddf5ae417900e51fd85d04d91c2dca08ee0250c4aff5756911d8cc521e45b41799bea004ba7a4cdaaa0cd95a081d690ae8207b1be1f SHA512 e2bdfa7e6352ba04b2ddeca200befccf49329b9a04c15a03c563fcd1e1b5ca169e359c78f899066170860ec70cbc9e7b689469d21956a04d7a7d70d0954b6322
+EBUILD vcrpy-4.1.1.ebuild 1797 BLAKE2B 87e84d360a0d88724e45bf24d096becc6254598d588cd2192aeb477da649288ff6f62fb27b21e5579ffef5a73c54436e4c803e35e2d7d24c3b3e5acf3821b6cc SHA512 10d6eb6e92d2278caf9a3cb35b7e9cbf2097f73f416e23d36252852f596d6f4a98054643bbe95080330b731a92252a23c095bc0056844eb0d38e915f47e8f3db
MISC metadata.xml 387 BLAKE2B 09c086ca73a9932b1ac06f46f7c7ef216db357fe831fd6d8f996acedcf24a636420752130597318f4cc0a8d11a584d2162a892ca412403d1bbf15cdd86a1fbaa SHA512 09ba6aaf53089115dc98031b4dba4d526864b6d38ba7950fc3fccd9c2b1a0e14702f5235b3923a41300fabd4152e06eae22e20e86b54795bee453a184bd8828e
diff --git a/dev-python/vcrpy/vcrpy-4.1.1.ebuild b/dev-python/vcrpy/vcrpy-4.1.1.ebuild
index d110bfca31a6..e54023e451ac 100644
--- a/dev-python/vcrpy/vcrpy-4.1.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-4.1.1.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
@@ -32,20 +31,24 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- # tests requiring Internet
- rm tests/integration/test_aiohttp.py || die
- rm tests/integration/test_boto.py || die
- sed -e 's:test_flickr_should_respond_with_200:_&:' \
- -e 's:test_amazon_doctype:_&:' \
- -i tests/integration/test_wild.py || die
- sed -e 's:testing_connect:_&:' \
- -i tests/unit/test_stubs.py || die
-
- distutils-r1_src_prepare
-}
-
python_test() {
+ local deselect=(
+ # these tests require Internet
+ tests/integration/test_aiohttp.py
+ tests/integration/test_boto.py
+ tests/integration/test_httpx.py
+ tests/integration/test_wild.py::test_flickr_should_respond_with_200
+ tests/integration/test_wild.py::test_amazon_doctype
+ tests/unit/test_stubs.py::TestVCRConnection::testing_connect
+
+ # probably unhappy about ssl module being more strict now
+ 'tests/integration/test_httplib2.py::test_effective_url[https]'
+ 'tests/integration/test_requests.py::test_effective_url[https]'
+ 'tests/integration/test_requests.py::test_redirects[https]'
+ 'tests/integration/test_urllib2.py::test_effective_url[https]'
+ 'tests/integration/test_urllib3.py::test_redirects[https]'
+ )
+
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- pytest -vv || die "Tests fail with ${EPYTHON}"
+ epytest ${deselect[@]/#/--deselect }
}