summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
commit325837835fc86686829aaa6acace3d3c06c74cea (patch)
tree6cc31680e4ce26ab26e863fd7b72d0ffe2d9366f /dev-python/vcrpy
parent7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (diff)
gentoo auto-resync : 08:10:2024 - 04:26:34
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.2.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 572ba1a8b31b..bb48defb4758 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,4 +1,6 @@
AUX vcrpy-6.0.1-httpbin-compat.patch 1921 BLAKE2B 7ac8e0fa08f38b2b1f3bf78f80485a32d2ca2a56bff4c9c70b42049a6ed37dadd25f25fedd77b578d7452b87bf74825b0bd062186f74c9cc6a7017be6fe189f7 SHA512 81b87869bf8af2b853ff5a336c45ac1b26ed8f49729e2da94859b621d1110a07081d280dfb541fab0a8bb2ad48c26be48a3966f17a7455242da0b150a569c0c8
DIST vcrpy-6.0.1.gh.tar.gz 337497 BLAKE2B a00571d7ed0dd895cc120e3e2615e8e6ea3e86344813e87f836a182be45389b200925ae2a02dc754b0b77db642d3be453b3b8c909b26197222b84fa95c6da804 SHA512 79ba9ea29db20ddc3db5676d7bdb05da17848eb126ed63d813a1d2b0de80573fff3afaec2ffe1af491a0310ce922c7545c4569035d0f5868f171db25965c217f
+DIST vcrpy-6.0.2.gh.tar.gz 338830 BLAKE2B 946c30bc7d0a5663b2dea8989b298665fba6ce63dcb59127e7e444a1384457d65838ba0b24bac7c6285196c3fe796014aa68373ebf902f3e4e8928b76df3a120 SHA512 7e6b86bd60d2a2bd9ca8843f08143ec75656fc017ef7a9df29d4ee45e09bf985e9591204c466372459eb7987951ac2dbc730783e127e0db610e25261656275b2
EBUILD vcrpy-6.0.1-r1.ebuild 1887 BLAKE2B a73cdc24a5b71d16dea079eac6f1bb22000215c1ba31b4931d4831e5280fd1abdbdc24f794b1fe454f101d88ed8bb7469bde1fc054227def1440ba4db8d81f52 SHA512 273f3a681aa016c760649baf1e96390dccd119ddcaf00eb39c40b3b4b98dfcfff97a15198f3a568009bd8de3dc59d763952e85a8a0cfd174d0bbfaf1fae969e0
+EBUILD vcrpy-6.0.2.ebuild 1831 BLAKE2B 8339973dae9954d6147abaa62aed0c1b08e6d1e10f0003cfb8c3f85eb878988e33ccf342c308311d75dd60b0ac6ce61309c3677c944c1e12100fa2ec8062894b SHA512 7b8e21f4bf0eeee8f03fbbafea556774fa59b9843d181b8ab0164df61d86fdd67bd189bb70ae9371bc7b8b3434db93968e5b2dfde379a6dd1118a60fa5f6b8de
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-6.0.2.ebuild b/dev-python/vcrpy/vcrpy-6.0.2.ebuild
new file mode 100644
index 000000000000..edc8b114a061
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-6.0.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-httpbin-2.0.0-r1[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests are failing with recent dev-python/werkzeug; losely related:
+ # https://github.com/kevin1024/vcrpy/issues/645
+ tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
+ tests/integration/test_urllib2.py::test_random_body
+ tests/integration/test_urllib2.py::test_multiple_requests
+ # Internet
+ "tests/integration/test_urllib3.py::test_post[https]"
+ )
+
+ local EPYTEST_IGNORE=(
+ # requires boto3
+ tests/integration/test_boto3.py
+ # Internet
+ tests/integration/test_tornado.py
+ tests/integration/test_aiohttp.py
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not online' -p httpbin -p rerunfailures --reruns=5
+}