summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/vcrpy
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild (renamed from dev-python/vcrpy/vcrpy-4.1.1.ebuild)28
2 files changed, 19 insertions, 11 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 663f58b5ff0f..842a8e17bef9 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,3 @@
DIST vcrpy-4.1.1.tar.gz 329508 BLAKE2B b6981150a8fd742301e0d7897d84855c741c97307bbb5c5751680f3d33d69d6333a18d714fcc14cb018f5dd6c02e840e1313136660c4459e2755d448fc0b07e9 SHA512 afa1904bff37bfd2d278ed49fa3982a357eb6bb113818b532044da0f11a9dd877cc152d7f0d81d88bdc0f870521b1241f6aecf959f668211904e3c6c7cea4ad8
-EBUILD vcrpy-4.1.1.ebuild 1797 BLAKE2B 87e84d360a0d88724e45bf24d096becc6254598d588cd2192aeb477da649288ff6f62fb27b21e5579ffef5a73c54436e4c803e35e2d7d24c3b3e5acf3821b6cc SHA512 10d6eb6e92d2278caf9a3cb35b7e9cbf2097f73f416e23d36252852f596d6f4a98054643bbe95080330b731a92252a23c095bc0056844eb0d38e915f47e8f3db
+EBUILD vcrpy-4.1.1-r1.ebuild 1798 BLAKE2B 93f6511d7b8f36910b79d61fd68333e2c1b912d099c011e2eaa6b8bb33462b640f7b319ad3e110bf826892507e9413e0c9e364cc92f8ef70829562f47f423750 SHA512 2ac1af65fdd13d862898dde4771f7dc5ac1e3e9c1236e85c6be171c13dc54af9445a59a33cf8bdc6e5a84b290ac568630d3296b8791b1ae14185196232e33049
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-4.1.1.ebuild b/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild
index e54023e451ac..e1d011d9d398 100644
--- a/dev-python/vcrpy/vcrpy-4.1.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild
@@ -1,15 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="https://github.com/kevin1024/vcrpy"
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -23,16 +30,17 @@ RDEPEND="
dev-python/urllib3[${PYTHON_USEDEP}]
dev-python/wrapt[${PYTHON_USEDEP}]
dev-python/yarl[${PYTHON_USEDEP}]
- "
+"
BDEPEND="
test? (
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
python_test() {
- local deselect=(
+ local EPYTEST_DESELECT=(
# these tests require Internet
tests/integration/test_aiohttp.py
tests/integration/test_boto.py
@@ -50,5 +58,5 @@ python_test() {
)
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest ${deselect[@]/#/--deselect }
+ epytest
}